]> code.ossystems Code Review - openembedded-core.git/commitdiff
chkconfig: pass CFLAGS to Makefile
authorJoe Slater <jslater@windriver.com>
Wed, 10 Oct 2012 22:16:43 +0000 (15:16 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 11:03:25 +0000 (12:03 +0100)
The environment CFLAGS is not used by the chkconfig
Makefile, so debug and optimization options are ignored.
So, we use RPM_OPT_FLAGS to pass CFLAGS into Makefile.

Upstream-Status:  Inappropriate [configuration]

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb

index 9e0e1a05f0a955c7f7f70545170b0179dea75810..0f6398f57ed0f5987dc1b3ab8d8dc9d182ac31c3 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
 
 DEPENDS = "libnewt popt"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
 
@@ -21,7 +21,10 @@ SRC_URI[sha256sum] = "18b497d25b2cada955c72810e45fcad8280d105f17cf45e2970f182712
 
 inherit autotools gettext
 
-EXTRA_OEMAKE += 'MANDIR="${mandir}" BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
+# Makefile uses RPM_OPT_fLAGS to construct CFLAGS
+#
+EXTRA_OEMAKE += 'RPM_OPT_FLAGS="${CFLAGS}" MANDIR="${mandir}" \
+                 BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
 
 do_install_append() {
     mkdir -p ${D}${sysconfdir}/chkconfig.d