]> code.ossystems Code Review - openembedded-core.git/commitdiff
piglit: add bash to RDEPENDS_piglit
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 2 Sep 2014 09:41:49 +0000 (02:41 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Sep 2014 09:24:20 +0000 (10:24 +0100)
Bash:
piglit/usr/lib/piglit/tests/asmparsertest/make_test_list.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/asmparsertest/vp-tex.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/glsl-1.10/variable-index-read.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/glsl-1.10/variable-index-write.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/arb_shader_texture_lod/compiler/make_tex_lod_tests.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/glsl-1.20/execution/outerProduct-const.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/glsl-1.20/execution/outerProduct.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/spec/glsl-1.20/compiler/built-in-functions/outerProduct-invalid-parameters.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/glslparsertest/glsl2/make_tex_lod_tests.sh:#!/bin/bash
piglit/usr/lib/piglit/tests/glslparsertest/glsl2/make_tex_rect_tests.sh:#!/bin/bash

The bash scripts are in the tests directory, we had planned to move the
tests into the ptest pkg, but that would make piglit unusable without
installing piglit-ptest.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/piglit/piglit_git.bb

index 5c013ef94fcd29139983f45eac599b39014f4d96..f468120f80b3c468f4cee9d3467728fb2642a073 100644 (file)
@@ -45,4 +45,7 @@ do_install() {
 
 FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
 
-RDEPENDS_${PN} = "python waffle python-json python-subprocess python-multiprocessing python-textutils python-netserver python-shell mesa-demos"
+RDEPENDS_${PN} = "python waffle python-json python-subprocess \
+       python-multiprocessing python-textutils python-netserver python-shell \
+       mesa-demos bash \
+       "