]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-setuptools: upgrade 42.0.2 -> 45.0.0
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 29 Jan 2020 09:07:31 +0000 (10:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Feb 2020 13:03:20 +0000 (13:03 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
meta/recipes-devtools/python/python-setuptools.inc
meta/recipes-devtools/python/python3-setuptools_45.0.0.bb [moved from meta/recipes-devtools/python/python3-setuptools_42.0.2.bb with 100% similarity]

index 169d1b155bdabfcf6a84b1f1d68dabb66c6edf8b..b1a6813b2e313dd4b9f1582db07796d59e14283e 100644 (file)
@@ -1,4 +1,4 @@
-From 5bba4f57f048016aa92ce5909e9e372db619554e Mon Sep 17 00:00:00 2001
+From 50e4ebce9f711391e2fa9f43906259e19ac00e63 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Tue, 17 Jul 2018 10:13:38 +0800
 Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -15,10 +15,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  1 file changed, 5 insertions(+)
 
 diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 05508ce..945e118 100755
+index 09066f8..d3039a5 100644
 --- a/setuptools/command/easy_install.py
 +++ b/setuptools/command/easy_install.py
-@@ -640,6 +640,11 @@ class easy_install(Command):
+@@ -649,6 +649,11 @@ class easy_install(Command):
              os.path.exists(tmpdir) and rmtree(rmtree_safe(tmpdir))
  
      def easy_install(self, spec, deps=False):
index d8bce7145eb742491b90d1ec85c4f8021803c55f..c697937887bcce73a513c604bb3cb66861603224 100644 (file)
@@ -10,8 +10,8 @@ inherit pypi
 
 SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
 
-SRC_URI[md5sum] = "5ac69b66a6f7d4785517017f37df28e9"
-SRC_URI[sha256sum] = "c5b372090d7c8709ce79a6a66872a91e518f7d65af97fca78135e1cb10d4b940"
+SRC_URI[md5sum] = "14898abd6f436eee58a5a2ba291fcbeb"
+SRC_URI[sha256sum] = "c46d9c8f2289535457d36c676b541ca78f7dcb736b97d02f50d17f7f15b583cc"
 
 DEPENDS += "${PYTHON_PN}"