]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: Add fix for cipher des-ede3-cfb1
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Thu, 13 Jun 2013 11:41:20 +0000 (16:41 +0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Jun 2013 15:44:36 +0000 (16:44 +0100)
Add patch file for one of the ciphers used in openssl, namely the cipher
des-ede3-cfb1. Details of the bug, without this patch, can be found here.
http://rt.openssl.org/Ticket/Display.html?id=2867

Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/openssl/openssl-1.0.1e/fix-cipher-des-ede3-cfb1.patch [new file with mode: 0644]
meta/recipes-connectivity/openssl/openssl_1.0.1e.bb

diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.1e/fix-cipher-des-ede3-cfb1.patch b/meta/recipes-connectivity/openssl/openssl-1.0.1e/fix-cipher-des-ede3-cfb1.patch
new file mode 100644 (file)
index 0000000..f0e1778
--- /dev/null
@@ -0,0 +1,22 @@
+Upstream-Status: Submitted
+
+This patch adds the fix for one of the ciphers used in openssl, namely
+the cipher des-ede3-cfb1. Complete bug log and patch is present here:
+http://rt.openssl.org/Ticket/Display.html?id=2867
+
+Signed-Off-By: Muhammad Shakeel <muhammad_shakeel@mentor.com>
+
+diff --git a/crypto/evp/e_des3.c b/crypto/evp/e_des3.c
+index 3232cfe..df84922 100644
+===================================================================
+--- a/crypto/evp/e_des3.c
++++ b/crypto/evp/e_des3.c
+@@ -173,7 +173,7 @@ static int des_ede3_cfb1_cipher(EVP_CIPHER_CTX *ctx, unsigned char *out,
+     size_t n;
+     unsigned char c[1],d[1];
+-    for(n=0 ; n < inl ; ++n)
++    for(n=0 ; n < inl*8 ; ++n)
+       {
+       c[0]=(in[n/8]&(1 << (7-n%8))) ? 0x80 : 0;
+       DES_ede3_cfb_encrypt(c,d,1,1,
index 61de3a694cd8c5d106826a21db77498c9927c911..bd6fd046a337c8f12cdeeaed066ff86e606de436 100644 (file)
@@ -30,6 +30,7 @@ SRC_URI += "file://configure-targets.patch \
             file://debian/debian-targets.patch \
             file://openssl_fix_for_x32.patch \
             file://openssl-fix-doc.patch \
+            file://fix-cipher-des-ede3-cfb1.patch \
             file://find.pl \
            "