]> code.ossystems Code Review - openembedded-core.git/commitdiff
ruby: add ptest
authorChangqing Li <changqing.li@windriver.com>
Thu, 11 Apr 2019 07:02:33 +0000 (15:02 +0800)
committerArmin Kuster <akuster808@gmail.com>
Sun, 14 Apr 2019 14:23:52 +0000 (07:23 -0700)
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/ruby/ruby.inc
meta/recipes-devtools/ruby/ruby/run-ptest [new file with mode: 0644]
meta/recipes-devtools/ruby/ruby_2.5.3.bb

index 28e21fee9cc0e53d0039ed57dfb4467356a8d2cc..1ecd087d7d2c1657422e8ed27524d7ec33cc3398 100644 (file)
@@ -24,7 +24,7 @@ SRC_URI = "http://cache.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
            "
 UPSTREAM_CHECK_URI = "https://www.ruby-lang.org/en/downloads/"
 
-inherit autotools
+inherit autotools ptest
 
 
 # This snippet lets compiled extensions which rely on external libraries,
diff --git a/meta/recipes-devtools/ruby/ruby/run-ptest b/meta/recipes-devtools/ruby/ruby/run-ptest
new file mode 100644 (file)
index 0000000..de7c415
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+test_fullname=`find test -name test_*.rb` 
+for i in ${test_fullname}; do 
+       ruby ./test/runner.rb ${i}  2>&1 > /dev/null
+       ret=$? 
+       if [ $ret != 0 ]; then
+               echo "FAIL: ${i}" 
+       else
+               echo "PASS: ${i}"         
+       fi 
+done 
index 173b44b377e1e6c012fd1062820535fe55cced56..519daf294ff14f286fd0ae16c73efa2f0a69fde4 100644 (file)
@@ -3,6 +3,7 @@ require ruby.inc
 SRC_URI += " \
            file://ruby-CVE-2017-9226.patch \
            file://ruby-CVE-2017-9228.patch \
+           file://run-ptest \
            "
 
 SRC_URI[md5sum] = "20c85b67846d49622ef3b24230803fef"
@@ -55,6 +56,13 @@ do_install_append_class-target () {
 
 }
 
+do_install_ptest () {
+    cp -rf ${S}/test ${D}${PTEST_PATH}/
+    cp -r ${S}/include ${D}/${libdir}/ruby/
+    test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
+    sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
+}
+
 PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
 
 SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
@@ -67,4 +75,6 @@ FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
 
 FILES_${PN} += "${datadir}/rubygems"
 
+FILES_${PN}-ptest_append_class-target += "${libdir}/ruby/include"
+
 BBCLASSEXTEND = "native"