]> code.ossystems Code Review - openembedded-core.git/commitdiff
util-linux: Example of pkg level INCOMPATIBLE_LICENSE
authorElizabeth Flanagan <elizabeth.flanagan@intel.com>
Fri, 23 Mar 2012 23:51:43 +0000 (16:51 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 25 Mar 2012 10:08:47 +0000 (11:08 +0100)
util-linux-lscpu provides an example of pkg level incompatible
license. In this instance, we've set the license for this specific
package as GPLv3. The other packages inherit the recipe LICENSE.

What this allows is the package to not be included on install to
the image.

Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/util-linux/util-linux_2.21.bb

index ab26fcd99a0c0b08c015b7377224246845e874e6..c0c8bc6edd2be410088ad0b87b5b689dd5c0fb2b 100644 (file)
@@ -3,7 +3,7 @@ PR = "r5"
 require util-linux.inc
 
 # note that `lscpu' is under GPLv3+
-LICENSE_util-linux-lscpu = "GPLv3+"
+LICENSE_${PN}-lscpu = "GPLv3+"
 
 SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
             file://util-linux-ng-2.16-mount_lock_path.patch \
@@ -16,16 +16,14 @@ SRC_URI[sha256sum] = "2813ae6fe0449b60402e122c2baf97f26aa53e6e2dd05591c6cbcdf67f
 
 # Only lscpu part is gplv3; rest of the code is not, 
 # so take out the lscpu parts while running non-gplv3 build.
+# The removal of the package should now occur during
+# the build if INCOMPATIBLE_LICENSE is set to GPLv3
+
 python () {
     d.setVar("REMOVELSCPU", "no")
     if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
         # avoid GPLv3
         d.setVar("REMOVELSCPU", "yes")
-        packages = (d.getVar("PACKAGES", False) or "").split()
-        if "util-linux-lscpu" in packages:
-            packages.remove("util-linux-lscpu")
-        d.setVar("PACKAGES", " ".join(packages))
-
         src_uri = (d.getVar("SRC_URI", False) or "").split()
         src_uri.append("file://remove-lscpu.patch")
         d.setVar("SRC_URI", " ".join(src_uri))