]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add EXTRA_IMAGE_FEATURES for ease of use in local.conf
authorRichard Purdie <richard@openedhand.com>
Thu, 10 Jan 2008 23:50:30 +0000 (23:50 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 10 Jan 2008 23:50:30 +0000 (23:50 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3461 311d38ba-8fff-0310-9ca6-ca027cbcb966

build/conf/local.conf.sample
meta/conf/bitbake.conf

index 9cdbe59d92b332816fa99c61cd48a0afaccace37..5e55f9277291ac28e6b5fc31f8e422268f2d7cd8 100644 (file)
@@ -35,7 +35,7 @@ DISTRO ?= "poky"
 # For bleeding edge / experimental / unstable package versions
 # DISTRO ?= "poky-bleeding"
 
-# IMAGE_FEATURES configuration of the generated images 
+# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images 
 # (Some of these are automatically added to certain image types)
 # "dbg-pkgs"     - add -dbg packages for all installed packages
 #                  (adds symbol information for debugging/profiling)
@@ -50,13 +50,13 @@ DISTRO ?= "poky"
 # There are other application targets too, see meta/classes/poky-image.bbclass 
 # and meta/packages/tasks/task-poky.bb for more details.
 
-IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
 
 # The default IMAGE_FEATURES above are too large for the mx31phy and 
 # c700/c750 machines which have limited space. The code below limits
 # the default features for those machines.
-IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
-IMAGE_FEATURES_mx31phy = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31phy = "tools-testapps debug-tweaks"
 
 # A list of packaging systems used in generated images
 # The first package type listed will be used for rootfs generation
index 49df8869a4816002661da34be5a1d3d003c66a39..75a69f6dac0be2e316b7afccddae72fe744de7a6 100644 (file)
@@ -588,6 +588,7 @@ MACHINE_EXTRA_RDEPENDS ?= ""
 MACHINE_EXTRA_RRECOMMENDS ?= ""
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+IMAGE_FEATURES += "${EXTRA_IMAGE_FEATURES}"
 
 COMBINED_FEATURES = "\
     ${@base_both_contain("DISTRO_FEATURES", "MACHINE_FEATURES", "alsa", d)} \