]> code.ossystems Code Review - openembedded-core.git/commitdiff
orinoco-conf: call update-modules to populate information from /etc/modutils
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 15:30:52 +0000 (15:30 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 15:30:52 +0000 (15:30 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2979 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/orinoco/files/hermes.conf [deleted file]
meta/packages/orinoco/files/spectrum.conf [deleted file]
meta/packages/orinoco/orinoco-conf_1.0.bb

diff --git a/meta/packages/orinoco/files/hermes.conf b/meta/packages/orinoco/files/hermes.conf
deleted file mode 100644 (file)
index 4937d35..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-device "orinoco_cs"
-  class "network"
-  module "hermes", "orinoco", "orinoco_cs"
-
-device "spectrum_cs"
-  class "network" module "hermes", "orinoco", "spectrum_cs"
-
-
-# This manfid was used for cards with Lucent/Agere and Intersil firmware.
-# orinoco_cs supports both types, so we don't need to distinguish them.
-
-card "Orinoco or Intersil Prism 2 Wireless"
-  manfid 0x0156,0x0002
-  bind "orinoco_cs"
-
-
-# Cards with Lucent/Agere firmware (Hermes chipset)
-
-card "Lucent Technologies Wavelan/IEEE"
-  version "Lucent Technologies", "WaveLAN/IEEE"
-  bind "orinoco_cs"
-
-card "Avaya World Card"
-  version "Avaya Communication", "Avaya Wireless PC Card"
-  bind "orinoco_cs"
-
-card "Cabletron RoamAbout 802.11 DS"
-  version "Cabletron", "RoamAbout 802.11 DS"
-  bind "orinoco_cs"
-
-card "ELSA AirLancer MC-11"
-  version "ELSA", "AirLancer MC-11"
-  bind "orinoco_cs"
-
-card "MELCO WLI-PCM-L11"
-  version "MELCO", "WLI-PCM-L11"
-  bind "orinoco_cs"
-
-card "ARtem Onair"
-  version "ARtem", "Onair"
-  bind "orinoco_cs"
-
-
-# Cards with Symbol firmware in flash (Spectrum24 chipset)
-
-card "LA4111 Spectrum24 Wireless LAN PC Card"
-  version "Symbol Technologies"
-  bind "orinoco_cs"
-
-card "3Com AirConnect"
-  version "3Com", "3CRWE737A AirConnect Wireless LAN PC Card"
-  bind "orinoco_cs"
-
-card "Intel PRO/Wireless 2011"
-  manfid 0x0089,0x0001
-  bind "orinoco_cs"
-
-card "Ericsson WLAN Card C11"
-  manfid 0x016b,0x0001
-  bind "orinoco_cs" 
-
-card "Nortel Networks e-mobility 802.11 Wireless LAN PC Card"
-  version "Nortel Networks", "emobility 802.11 Wireless LAN PC Card", "1.00"
-  bind "orinoco_cs"
-
-card "D-Link DWL-650H"
-  version "D-Link Corporation", "D-Link DWL-650H 11Mbps WLAN Adapter"
-  bind "orinoco_cs"
-
-
-# Cards with Symbol firmware without flash memory (Spectrum24 Trilogy).
-# These cards need a separate driver that loads the firmware.
-
-card "LA4100 Spectrum24 CF WLAN Card"
-  manfid 0x026c, 0x0001
-  bind "spectrum_cs"
-
-card "Socket Communications CF+ LP WLAN Card"
-  manfid 0x0104, 0x0001
-  bind "spectrum_cs"
-
-card "Intel PRO/Wireless 2011B"
-  manfid 0x0089, 0x0001
-  bind "spectrum_cs"
-
diff --git a/meta/packages/orinoco/files/spectrum.conf b/meta/packages/orinoco/files/spectrum.conf
deleted file mode 100644 (file)
index 8494555..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-device "spectrum_cs"
-  class "network" module "hermes", "orinoco", "spectrum_cs"
-
-card "LA4100 Spectrum24 CF WLAN Card"
-  manfid 0x026c, 0x0001
-  bind "spectrum_cs"
-
-card "LA4137 Spectrum24 CF WLAN CARD"
- manfid 0x014d, 0x0001
-  bind "spectrum_cs"
-
-card "Socket Communications CF+ LP WLAN Card"
-  manfid 0x0104, 0x0001
-  bind "spectrum_cs"
-
-card "Intel PRO/Wireless 2011B"
-  manfid 0x0089, 0x0001
-  bind "spectrum_cs"
index 97b860f2cf38c67216d7b4562d82470b6417ad12..a7345229796b1a7fa581647b5aca64dd877ddde1 100644 (file)
@@ -2,8 +2,9 @@ DESCRIPTION = "PCMCIA-cs configuration files for Hermes (Orinoco) wireless LAN c
 SECTION = "kernel/modules"
 PRIORITY = "optional"
 LICENSE = "GPL"
+RDEPENDS = "update-modules"
 PACKAGE_ARCH = "all"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "file://spectrum.conf \
            file://hermes.conf \
@@ -16,3 +17,14 @@ do_install() {
         install -m 0644 ${WORKDIR}/hermes.conf ${D}${sysconfdir}/pcmcia/
         install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
 }
+
+pkg_postinst () {
+       if [ -n "$D" ]; then
+               exit 1
+       fi
+       update-modules || true
+}
+
+pkg_postrm () {
+       update-modules || true
+}