]> code.ossystems Code Review - openembedded-core.git/commitdiff
kmod: Add patch to fix seperate build dir of ptest
authorSaul Wold <sgw@linux.intel.com>
Wed, 9 Oct 2013 22:35:46 +0000 (15:35 -0700)
committerRobert Yang <liezhi.yang@windriver.com>
Wed, 11 Dec 2013 02:12:17 +0000 (21:12 -0500)
(From OE-Core master rev: 68322eadd1d9456e606b375c2f4181725784c292)

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-kernel/kmod/kmod.inc
meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch [new file with mode: 0644]

index 633258b05e39d0884952c5a83b823b1c7017a57a..880a53aa07564c46aa912e3b1ba6467715f700ad 100644 (file)
@@ -20,6 +20,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git \
            file://run-ptest \
            file://ptest.patch \
            file://remove_parallel_tests.patch \
+           file://fix-seperatebuilddir.patch \
           "
 
 SRCREV = "3b38c7fcb58be4ddc34f90454c5f5dc3693d2d85"
diff --git a/meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch b/meta/recipes-kernel/kmod/kmod/fix-seperatebuilddir.patch
new file mode 100644 (file)
index 0000000..b090eb5
--- /dev/null
@@ -0,0 +1,34 @@
+
+If we are not building in the existing source tree, the testsuite
+directory will not exist so the cp of the stamp-rootfs would fail.
+
+Also added buildtest-TESTS so they could be build in the cross env,
+without running the tests.
+
+Upstream-Status: Accepted
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am
++++ git/Makefile.am
+@@ -131,7 +131,7 @@ endif
+ ROOTFS = testsuite/rootfs
+ ROOTFS_PRISTINE = $(top_srcdir)/testsuite/rootfs-pristine
+-CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && \
++CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && mkdir -p $(dir $(ROOTFS)) && \
+                               cp -r $(ROOTFS_PRISTINE) $(ROOTFS) && \
+                               touch testsuite/stamp-rootfs && \
+                               find $(ROOTFS) -type d -exec chmod +w {} \; )
+@@ -217,6 +217,9 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
+ distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
++buildtest-TESTS:
++      $(MAKE) $(AM_MAKEFLAGS) $(check_LTLIBRARIES) $(check_PROGRAMS)
++
+ install-ptest:
+       @$(MKDIR_P) $(DESTDIR)/testsuite
+       @for file in $(TESTSUITE); do \