]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: Add DISTRO Info to /etc/lsb-release file also add util-linux to DEPENDS
authorSaul Wold <sgw@linux.intel.com>
Tue, 17 Apr 2012 22:02:11 +0000 (15:02 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Apr 2012 22:15:46 +0000 (23:15 +0100)
Add the DISTRO* fields to the /etc/lsb-release file so the distro
parsing code can find standard information about the Poky Distro
when using the Self-Hosted Image.

The lsb_release command uses getopt which is provided by util-linux

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsb_1.4.bb

index f2f25ba6399a18551a117a4d90161b0426e2848e..e414d93260d6bdd0719a4109c364ea6a7084bcd0 100644 (file)
@@ -4,6 +4,8 @@ HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
 LICENSE = "GPLv2+"
 PR = "r2"
 
+DEPENDS="util-linux"
+
 LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/project/lsb/lsb_release/${PV}/lsb-release-${PV}.tar.gz \
@@ -31,6 +33,9 @@ do_install(){
                echo -n "core-4.1-${TARGET_ARCH}" >>  ${D}/etc/lsb-release
        fi
        echo "\"" >> ${D}/etc/lsb-release
+       echo "DISTRIB_ID=${DISTRO}" >> ${D}/etc/lsb-release
+       echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}/etc/lsb-release
+       echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}/etc/lsb-release
        
        if [ "${TARGET_ARCH}" == "i586" ];then
                mkdir -p ${D}/etc/lsb-release.d