]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-sato: SDK should contain intltool and glib-2.0 tools for NLS
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 11 Jan 2017 01:09:03 +0000 (01:09 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 22:45:54 +0000 (22:45 +0000)
The SDK (and its tests) need these tools. We happened to be finding them
from the native tools in PATH but recipe specific sysroots prevents that.

This fixes the SDK to work as originally intended and contain these tools.

We have to clear this in the eSDK case since the _append can't be overridden
from the class. Ugly, but we'll have to come back to this issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/images/core-image-sato.bb

index e3246d2b671746651c3142f0776b19d8dd15c169..99dad11532ef7e7eafd31a9b0c2742fe28f025fd 100644 (file)
@@ -9,3 +9,6 @@ LICENSE = "MIT"
 inherit core-image
 
 IMAGE_INSTALL += "packagegroup-core-x11-sato-games"
+
+TOOLCHAIN_HOST_TASK_append = " nativesdk-intltool nativesdk-glib-2.0"
+TOOLCHAIN_HOST_TASK_remove_task-populate-sdk-ext = " nativesdk-intltool nativesdk-glib-2.0"