]> code.ossystems Code Review - openembedded-core.git/commitdiff
netbase: use snapshot.debian.org for SRC_URI
authorMaxin B. John <maxin.john@intel.com>
Thu, 28 Jul 2016 12:24:21 +0000 (15:24 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2016 10:46:38 +0000 (11:46 +0100)
Using ${DEBIAN_MIRROR} for SRC_URI doesn't work very well as that will
only contain releases that are currently in Debian. So, move all of SRC_URI
to the .bb so it can use snapshot.debian.org instead, and set
UPSTREAM_CHECK_URI to ${DEBIAN_MIRROR} so upstream release checking continues
to work.

[YOCTO #10040]

Signed-off-by: Maxin B. John <maxin.john@intel.com>
meta/recipes-core/netbase/netbase_5.3.bb

index ccd89ff84f62e0a534018fcb368bd91170411050..543596a3d99f0f25f187b915da6f1a4b3ddb9a3f 100644 (file)
@@ -6,13 +6,14 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://debian/copyright;md5=3dd6192d306f582dee7687da3d8748ab"
 PE = "1"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.xz \
+SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/n/${BPN}/${BPN}_${PV}.tar.xz \
            file://netbase-add-rpcbind-as-an-alias-to-sunrpc.patch \
            file://hosts"
 
 SRC_URI[md5sum] = "2637a27fd3de02a278d2b5be7e6558c1"
 SRC_URI[sha256sum] = "81f6c69795044d62b8ad959cf9daf049d0545fd466c52860ad3f933b1e97b88b"
 
+UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/n/netbase/"
 do_install () {
        install -d ${D}/${mandir}/man8 ${D}${sysconfdir}
        install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts