]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-native: Avoid use of getentropy/getrandom
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Aug 2017 13:00:21 +0000 (14:00 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 6 Sep 2017 16:01:03 +0000 (17:01 +0100)
getentropy/random() is only available in glibc 2.25+ and uninative may relocate
binaries onto systems that don't have this function. For now, force the code to
the older codepaths until we can come up with a better solution for this kind of
issue.

(From OE-Core rev: 92bda0024d85ae78345665cc2f9646c9881ed61b)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-native_3.5.2.bb

index edcf2244f57e595e02c3c29cd40b864b814b8419..3f4b567278ca9919d54ed451d4de19c320ffa033 100644 (file)
@@ -43,7 +43,8 @@ inherit native
 
 require python-native-${PYTHON_MAJMIN}-manifest.inc
 
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
+# uninative may be used on pre glibc 2.25 systems which don't have getentropy
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip ac_cv_func_getentropy=no"
 
 EXTRA_OEMAKE = '\
   LIBC="" \
@@ -58,6 +59,7 @@ PYTHONLSBOPTS = ""
 
 do_configure_append() {
        autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
+       sed -i -e 's,#define HAVE_GETRANDOM 1,/\* #undef HAVE_GETRANDOM \*/,' ${B}/pyconfig.h
 }
 
 do_install() {