]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add patch to fix crashes caused by udevtrigger on startup.
authorRobert Bradford <rob@openedhand.com>
Thu, 21 Feb 2008 15:20:17 +0000 (15:20 +0000)
committerRobert Bradford <rob@openedhand.com>
Thu, 21 Feb 2008 15:20:17 +0000 (15:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3843 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-2.6.23/em-x270/em-x270-battery-sysfs-fix.patch [new file with mode: 0644]
meta/packages/linux/linux_2.6.23.bb

diff --git a/meta/packages/linux/linux-2.6.23/em-x270/em-x270-battery-sysfs-fix.patch b/meta/packages/linux/linux-2.6.23/em-x270/em-x270-battery-sysfs-fix.patch
new file mode 100644 (file)
index 0000000..51ec773
--- /dev/null
@@ -0,0 +1,40 @@
+Index: linux-2.6.23/arch/arm/mach-pxa/em-x270-pm.c
+===================================================================
+--- linux-2.6.23.orig/arch/arm/mach-pxa/em-x270-pm.c   2008-02-21 14:30:06.000000000 +0000
++++ linux-2.6.23/arch/arm/mach-pxa/em-x270-pm.c        2008-02-21 14:59:24.000000000 +0000
+@@ -461,6 +461,9 @@
+                       else {
+                               val->intval = POWER_SUPPLY_STATUS_NOT_CHARGING;
+                       }
++              } 
++              else {
++                      val->intval = POWER_SUPPLY_STATUS_NOT_CHARGING;
+               }
+       }
+       else {
+@@ -547,8 +550,9 @@
+               pr_debug("%s: MODEL = %s\n", __FUNCTION__, val->strval);
+               break;
+       default: break;
++               return -1;
+       }
+-      
++
+       return 0;
+ }
+Index: linux-2.6.23/drivers/power/em_x270_battery.c
+===================================================================
+--- linux-2.6.23.orig/drivers/power/em_x270_battery.c  2008-02-21 12:21:53.000000000 +0000
++++ linux-2.6.23/drivers/power/em_x270_battery.c       2008-02-21 15:00:51.000000000 +0000
+@@ -418,8 +418,9 @@
+               pr_debug("%s: MODEL = %s\n", __FUNCTION__, val->strval);
+               break;
+       default: break;
++              return -1;
+       }
+-      
++
+       return 0;
+ }
index 8c525d6e800a8ebf0fc9404860f9429e1bccef40..a517defd0f7de1636883a0621861d449604c5986 100644 (file)
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE_em-x270 = "1"
 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
 DEFAULT_PREFERENCE_mpc8323e-rdb = "1"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
           file://binutils-buildid-arm.patch;patch=1 \
@@ -15,7 +15,8 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
           "
 
 SRC_URI_append_em-x270 = "\
-          file://em-x270.patch;patch=1 "
+          file://em-x270.patch;patch=1 \
+          file://em-x270-battery-sysfs-fix.patch;patch=1 "
 
 SRC_URI_append_cm-x270 = "\
        file://0001-cm-x270-base2.patch;patch=1 \