]> code.ossystems Code Review - openembedded-core.git/commitdiff
rt-tests: fix gzip command
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 3 Feb 2015 03:15:31 +0000 (19:15 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Feb 2015 22:26:09 +0000 (22:26 +0000)
The "-c" doesn't work in command "gzip file -c", need use "gzip -c file"

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-rt/rt-tests/files/Makefile-fix-gzip-command.patch [new file with mode: 0644]
meta/recipes-rt/rt-tests/rt-tests.inc

diff --git a/meta/recipes-rt/rt-tests/files/Makefile-fix-gzip-command.patch b/meta/recipes-rt/rt-tests/files/Makefile-fix-gzip-command.patch
new file mode 100644 (file)
index 0000000..0a35ddc
--- /dev/null
@@ -0,0 +1,30 @@
+From 07b5ed42d7041ccc084889eaa96817aa097bf461 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Tue, 3 Feb 2015 03:10:25 +0000
+Subject: [PATCH] Makefile: fix gzip command
+
+The "-c" doesn't work in command "gzip file -c", need use "gzip -c file"
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 219a591..c7d147a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -144,7 +144,7 @@ install_hwlatdetect: hwlatdetect
+               install -D -m 755 src/hwlatdetect/hwlatdetect.py $(DESTDIR)$(PYLIB)/hwlatdetect.py ; \
+               rm -f "$(DESTDIR)$(bindir)/hwlatdetect" ; \
+               ln -s $(PYLIB)/hwlatdetect.py "$(DESTDIR)$(bindir)/hwlatdetect" ; \
+-              gzip src/hwlatdetect/hwlatdetect.8 -c >"$(DESTDIR)$(mandir)/man8/hwlatdetect.8.gz" ; \
++              gzip -c src/hwlatdetect/hwlatdetect.8 >"$(DESTDIR)$(mandir)/man8/hwlatdetect.8.gz" ; \
+       fi
+ .PHONY: release
+-- 
+2.0.1
+
index 7fbe6d45b8caef15c0ef4869d21a39f25e44e4b9..4942701531b62d12d6f5edd0f8b4c1077655d5c0 100644 (file)
@@ -7,6 +7,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git
            file://0002-rt-tests-Break-out-install_hwlatdetect.patch \
            file://added-missing-dependencies.patch \
            file://hackbench-fix-error-check.patch \
+           file://Makefile-fix-gzip-command.patch \
 "
 
 S = "${WORKDIR}/git"