]> code.ossystems Code Review - openembedded-core.git/commitdiff
dhcp: Use -fcommon compiler option
authorKhem Raj <raj.khem@gmail.com>
Wed, 5 Aug 2020 06:14:49 +0000 (23:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Aug 2020 14:12:34 +0000 (15:12 +0100)
This ensures -fcommon is still used when compiler defaults to
-fno-common in gcc10 and clang11

Fixes
dhcp-4.4.2/server/mdb.c:70: multiple definition of `dhcp_type_host'; dhcpd-omapi.o:/usr/src/debug/dhcp/4.4.2-r0/dhcp-4.4.2/server/omapi.c:50: first defined here

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb

index b56a204821d05a6219b08aa8e63838db8d9c86db..cf4af8260996cd64fc7df60d4802e775f7e37d2e 100644 (file)
@@ -19,3 +19,5 @@ LDFLAGS_append = " -pthread"
 
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[bind-httpstats] = "--with-libxml2,--without-libxml2,libxml2"
+
+CFLAGS += "-fcommon"