]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add gconf-vfs_svn and gnome-vfs-dbus_2.8.4.4.bb from OE and add gconf-lossage patch.
authorRichard Purdie <richard@openedhand.com>
Wed, 18 Jan 2006 19:08:01 +0000 (19:08 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 18 Jan 2006 19:08:01 +0000 (19:08 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@223 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/gnome/gconf-dbus_cvs.bb
openembedded/packages/gnome/gconf-dbus_svn.bb [new file with mode: 0644]
openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch [new file with mode: 0644]
openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb [new file with mode: 0644]
openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb

index 39908692ec42696b6fe827d55dd8d4a4dfeae16b..13241bdc214abbb9116de610f3d0d60f4b56b523 100755 (executable)
@@ -1,5 +1,3 @@
-DEFAULT_PREFERENCE = "-1"
-
 SECTION = "x11/utils"
 DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
 DESCRIPTION = "Settings daemon using DBUS for communication."
@@ -9,19 +7,17 @@ PROVIDES = "gconf"
 RPROVIDES_${PN} = "gconf"
 RPROVIDES_${PN}-dev = "gconf-dev"
 
-PV = "0.0cvs${CVSDATE}"
-PR = "r6"
+PV = "0.0+cvs${CVSDATE}"
+PR = "r8"
 
 SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gconf;tag=gconf-dbus-2-6 \
            file://gconf-dbus-update.patch;patch=1;pnum=0 \
           file://69gconfd-dbus"
 
-FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir}"
-
+inherit pkgconfig autotools
 S = "${WORKDIR}/gconf"
 
-
-inherit pkgconfig autotools
+FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*"
 
 EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
 
@@ -37,4 +33,6 @@ do_stage() {
 do_install_append () {
        install -d ${D}/${sysconfdir}/X11/Xsession.d
        install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
+       install -d ${D}/${datadir}/dbus-1.0/services/
+       install -m 644  gconf/gconf.service ${D}${datadir}/dbus-1.0/services/ 
 }
diff --git a/openembedded/packages/gnome/gconf-dbus_svn.bb b/openembedded/packages/gnome/gconf-dbus_svn.bb
new file mode 100644 (file)
index 0000000..675b655
--- /dev/null
@@ -0,0 +1,38 @@
+SECTION = "x11/utils"
+DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
+DESCRIPTION = "Settings daemon using DBUS for communication."
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+PROVIDES = "gconf"
+RPROVIDES_${PN} = "gconf"
+RPROVIDES_${PN}-dev = "gconf-dev"
+
+PV = "0.0+svn${CVSDATE}"
+PR = "r0"
+
+SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
+           file://gconf-dbus-update.patch;patch=1;pnum=0 \
+          file://69gconfd-dbus"
+
+inherit pkgconfig autotools
+S = "${WORKDIR}/trunk"
+
+FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*"
+
+EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
+
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+do_stage() {
+        oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+        install -d ${STAGING_INCDIR}/gconf/2/gconf/
+        ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+        install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}
+
+do_install_append () {
+       install -d ${D}/${sysconfdir}/X11/Xsession.d
+       install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
+       install -d ${D}/${datadir}/dbus-1.0/services/
+       install -m 644  gconf/gconf.service ${D}${datadir}/dbus-1.0/services/ 
+}
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch b/openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch
new file mode 100644 (file)
index 0000000..3dbc130
--- /dev/null
@@ -0,0 +1,11 @@
+--- gnome-vfs-2.6.0/configure.in~      2004-03-22 12:36:23.000000000 +0000
++++ gnome-vfs-2.6.0/configure.in       2004-06-07 16:04:34.000000000 +0100
+@@ -154,7 +154,7 @@
+ AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
+ if test x"$GCONFTOOL" = xno; then
+-  AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
++  AC_MSG_WARN([gconftool-2 executable not found in your path - should be installed with GConf])
+ fi
+ AM_GCONF_SOURCE_2
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb b/openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb
new file mode 100644 (file)
index 0000000..4f2a861
--- /dev/null
@@ -0,0 +1,91 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+PR = "r1"
+PROVIDES = "gnome-vfs"
+RPROVIDES = "gnome-vfs"
+
+inherit gnome pkgconfig
+
+DEPENDS = "libxml2 gconf-dbus dbus bzip2 gnome-mime-data zlib samba-3.0.14a"
+RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
+
+
+SRC_URI = "http://ftp.imendio.com/pub/extra/${PN}/${PN}-${PV}.tar.gz \
+           file://gssapi.patch;patch=1;pnum=1 \
+           file://gconftool-lossage.patch;patch=1;pnum=1"
+
+EXTRA_OECONF = "--with-ipc=dbus"
+
+FILES_${PN} += " ${libdir}/vfs"
+FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include"
+FILES_${PN}-doc += " ${datadir}/gtk-doc"
+
+GNOME_VFS_HEADERS = " \
+gnome-vfs-utils.h \
+gnome-vfs-application-registry.h \
+gnome-vfs-async-ops.h \
+gnome-vfs-ops.h \
+gnome-vfs-uri.h \
+gnome-vfs-standard-callbacks.h \
+gnome-vfs-module-callback.h \
+gnome-vfs-context.h \
+gnome-vfs-file-info.h \
+gnome-vfs-directory.h \
+gnome-vfs-mime-monitor.h \
+gnome-vfs-mime-handlers.h \
+gnome-vfs-result.h \
+gnome-vfs-job-limit.h \
+gnome-vfs-file-size.h \
+gnome-vfs-mime-utils.h \
+gnome-vfs-find-directory.h \
+gnome-vfs-init.h \
+gnome-vfs-handle.h \
+gnome-vfs.h \
+gnome-vfs-cancellation.h \
+gnome-vfs-xfer.h \
+gnome-vfs-monitor.h \
+gnome-vfs-types.h \
+gnome-vfs-volume-monitor.h \
+gnome-vfs-drive.h \
+gnome-vfs-volume.h \
+gnome-vfs-enum-types.h \
+gnome-vfs-address.h \
+gnome-vfs-dns-sd.h \
+gnome-vfs-mime-info-cache.h \
+gnome-vfs-resolve.h"
+
+GNOME_VFS_MODULE_HEADERS = " \
+gnome-vfs-mime-info.h \
+gnome-vfs-transform.h \
+gnome-vfs-ssl.h \
+gnome-vfs-inet-connection.h \
+gnome-vfs-socket.h \
+gnome-vfs-parse-ls.h \
+gnome-vfs-method.h \
+gnome-vfs-cancellable-ops.h \
+gnome-vfs-module.h \
+gnome-vfs-module-shared.h \
+gnome-vfs-module-callback-module-api.h \
+gnome-vfs-mime.h \
+gnome-vfs-socket-buffer.h"
+
+do_stage() {
+       oe_libinstall -so -C libgnomevfs libgnomevfs-2 ${STAGING_LIBDIR}
+       install -d ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs
+       for i in ${GNOME_VFS_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs/; done
+       install -d ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs
+       for i in ${GNOME_VFS_MODULE_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs/; done
+}
+
+do_install() {
+       oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}
+
+PACKAGES_DYNAMIC = "gnome=vfs-plugin-*"
+
+python populate_packages_prepend () {
+       print bb.data.getVar('FILES_gnome-vfs', d, 1)
+
+       plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
+       do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
+}
index 244f6516f22e56de13715c8b50a574df5f1adbee..87def47a2deb43cd3eb6983785a4c222cc3e1d41 100755 (executable)
@@ -15,6 +15,7 @@ PR = "r4"
 
 SRC_URI = "svn://anonymous@developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=http \
           file://no-gtk-doc.patch;patch=1 \
+          file://gconftool-lossage.patch;patch=1 \
           file://gssapi.patch;patch=1"
 S = "${WORKDIR}/trunk"