]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/bsp: update to reference FILESEXTRAPATHS
authorJoshua Lock <josh@linux.intel.com>
Fri, 22 Oct 2010 12:50:14 +0000 (13:50 +0100)
committerJoshua Lock <josh@linux.intel.com>
Fri, 22 Oct 2010 12:56:31 +0000 (13:56 +0100)
It's no longer neccesarry to define THISDIR and FILESPATH in each bbappend
recipe. Should you need to reference extra files you should use FILESEXTRAPATHS

Signed-off-by: Joshua Lock <josh@linux.intel.com>
documentation/poky-ref-manual/bsp.xml

index 9982f9e739ea88a1a2b699775d60e756cf62fa99..acb9f38e190820a2538988017a0a51f74bfb7dd2 100644 (file)
@@ -284,13 +284,13 @@ meta-bsp/packages/image-creator/image-creator-native_0.1.bb
             This allows the BSP layer to poke around and do whatever it might want to customise
             the original recipe.
 
-            .bbappend is expected to include the below two lines in the head (which may be changed
-            in the future):
+            If your recipe needs to reference extra files it can use the FILESEXTRAPATH variable
+            to specify their location. The example below shows extra files contained in a folder
+            called ${PN} (the package name).
             </para>
 
             <programlisting>
-THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
-FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
             </programlisting>
 
             <para>