]> code.ossystems Code Review - openembedded-core.git/commitdiff
kmod: fix zlib dependency
authorMartin Jansa <martin.jansa@gmail.com>
Mon, 30 Dec 2013 14:50:18 +0000 (15:50 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jan 2014 12:54:51 +0000 (12:54 +0000)
* unlike BBCLASSEXTENDed native support, dependencies in kmod-native doesn't get
  automatic -native suffix, so kmod-native was depending on target zlib.
* move the dependency from .inc and apply it with right suffix

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/kmod/kmod-native_git.bb
meta/recipes-kernel/kmod/kmod.inc
meta/recipes-kernel/kmod/kmod_git.bb

index fccc39bb3756d31cf6dce3e1b5dbdc3020d67278..6600413476c31ca29869c04d349e2bc5b61e2593 100644 (file)
@@ -2,6 +2,9 @@
 # Released under the MIT license (see COPYING.MIT for the terms)
 
 require kmod.inc
+
+DEPENDS += "zlib-native"
+
 inherit native
 
 SRC_URI += "file://0001-Fix-build-with-older-gcc-4.6.patch \
index 3eef69aed82600acb996e8e38e6b7ba7ea644f34..94724e45b831e62a9ebbd64f0f1125fc6e679921 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "GPL-2.0+ & LGPL-2.1+"
 LICENSE_libkmod = "LGPL-2.1+"
 SECTION = "base"
 
-DEPENDS += "pkgconfig-native zlib"
+DEPENDS += "pkgconfig-native"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://libkmod/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
index f90b9aaec9c2954e7f29db518753a027a8646004..c55cbd3e1e23b22cf04ff35c2fc42e8021e4024d 100644 (file)
@@ -3,6 +3,7 @@
 
 require kmod.inc
 
+DEPENDS += "zlib"
 PROVIDES += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
 RPROVIDES_${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
 RCONFLICTS_${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"