]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-environment: Ensure all multilib dependencies are accounted for
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 20 Jan 2017 13:55:47 +0000 (13:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 20 Jan 2017 14:27:13 +0000 (14:27 +0000)
Currently the recipe depends on the mulitlib libcs all being built
but the dependencies don't account for this. Fix the DEPENDS so
that the requires pieces are all built first rather than relying on
luck.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/meta-environment.bb

index a250cc89fedc116ff1435480b72e97ed8bc19c75..a2ed229100fce60ce094c8adfbcdb4dd5cc7b899 100644 (file)
@@ -19,6 +19,10 @@ SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${REAL_MULTIMACH_TARGET_SYS}"
 
 inherit cross-canadian
 
+# Need to ensure we have the virtual mappings and site files for all multtilib 
+# variants
+DEPENDS += "${@all_multilib_tune_values(d, 'TOOLCHAIN_NEED_CONFIGSITE_CACHE')}"
+
 do_generate_content[cleandirs] = "${SDK_OUTPUT}"
 do_generate_content[dirs] = "${SDK_OUTPUT}/${SDKPATH}"
 python do_generate_content() {