]> code.ossystems Code Review - openembedded-core.git/commitdiff
libuser: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 14:18:06 +0000 (14:18 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 17:04:56 +0000 (17:04 +0000)
Fix out of tree builds and a parallel make race, see the patch header
for details.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libuser/libuser/fixsepbuild.patch [new file with mode: 0644]
meta/recipes-extended/libuser/libuser_0.58.bb

diff --git a/meta/recipes-extended/libuser/libuser/fixsepbuild.patch b/meta/recipes-extended/libuser/libuser/fixsepbuild.patch
new file mode 100644 (file)
index 0000000..27e6bc6
--- /dev/null
@@ -0,0 +1,26 @@
+Fix out of tree build errors and parallel make issues. The mkdir commands 
+can race each other. The srcdir variable is a complete path so a ../ prefix makes
+no sense.
+
+Upstream-Status: Pending
+
+RP 2013/03/21
+
+Index: libuser/docs/Makefile.am
+===================================================================
+--- libuser/docs.orig/Makefile.am      2012-11-08 02:25:58.000000000 +0000
++++ libuser/docs/Makefile.am   2013-03-21 14:15:40.756950231 +0000
+@@ -13,9 +13,9 @@
+               < $(srcdir)/libuser.conf.5.in > $@
+ sgml/libuser.txt: $(srcdir)/sgml/libuser.sgml
+-      [ -d sgml ] || mkdir sgml
+-      cd sgml; sgml2txt ../$(srcdir)/sgml/libuser.sgml
++      [ -d sgml ] || mkdir sgml || true
++      cd sgml; sgml2txt $(srcdir)/sgml/libuser.sgml
+ sgml/libuser.html: $(srcdir)/sgml/libuser.sgml
+-      [ -d sgml ] || mkdir sgml
+-      cd sgml; sgml2html ../$(srcdir)/sgml/libuser.sgml
++      [ -d sgml ] || mkdir sgml || true
++      cd sgml; sgml2html $(srcdir)/sgml/libuser.sgml
index fbd3dd5bdfc0016bc570a290e92ed6a3ffd07578..c1fe49deee23a3815ac960c4da51d174d38806a9 100644 (file)
@@ -11,7 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
 
 SECTION = "base"
 
-SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz"
+SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz \
+           file://fixsepbuild.patch"
 
 SRC_URI[md5sum] = "1fc3ef3f3a3955b2d78562ff4daed793"
 SRC_URI[sha256sum] = "12a0c09d016d80687e04227a00a89e3c056d3b48bfa2444a9028e6474d8e1dbd"