]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: tweak for v5.3+
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 14 Aug 2019 15:31:29 +0000 (11:31 -0400)
committerArmin Kuster <akuster808@gmail.com>
Sun, 8 Sep 2019 15:31:14 +0000 (08:31 -0700)
The 5.3 kernel has two changes that require tweaks to the minimal
kernel-devsrc package.

4ce97317f [x86/purgatory: Do not use __builtin_memcpy and __builtin_memset]

  This change removes the need for arch/x86/purgatory/string.c and
  instead reuses a copy in arch/x86/boot/compressed/, so we can't copy
  the file anymore. To support older kernels, we make the copy survive
  the non-existence of the file.

b1663d7e [docs: Kbuild/Makefile: allow check for missing docs at build time]

  This change adds the sourceing of Documentation/Kbuild to the top
  level Kbuild file. So we now leave the copy of Documention/'s Kbuild
  in the devsrc.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-kernel/linux/kernel-devsrc.bb

index 5ec5929735c92d6eed948be8f1e936880d71ef46..3900489ac50eb17f67dc60b09a4aeafd950567d3 100644 (file)
@@ -65,7 +65,6 @@ do_install() {
     )
 
     # then drop all but the needed Makefiles/Kconfig files
-    rm -rf $kerneldir/build/Documentation
     rm -rf $kerneldir/build/scripts
     rm -rf $kerneldir/build/include
 
@@ -205,11 +204,12 @@ do_install() {
            cp -a --parents arch/x86/purgatory/sha256.c $kerneldir/build/ 2>/dev/null || :
 
            cp -a --parents arch/x86/purgatory/stack.S $kerneldir/build/
-           cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/
+           cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/ 2>/dev/null || :
            cp -a --parents arch/x86/purgatory/setup-x86_64.S $kerneldir/build/
            cp -a --parents arch/x86/purgatory/entry64.S $kerneldir/build/
            cp -a --parents arch/x86/boot/string.h $kerneldir/build/
            cp -a --parents arch/x86/boot/string.c $kerneldir/build/
+           cp -a --parents arch/x86/boot/compressed/string.c $kerneldir/build/ 2>/dev/null || :
            cp -a --parents arch/x86/boot/ctype.h $kerneldir/build/
        fi