]> code.ossystems Code Review - openembedded-core.git/commitdiff
foomatic-filters: Disable filter checking
authorMark Hatle <mark.hatle@windriver.com>
Thu, 22 Sep 2011 17:12:10 +0000 (12:12 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 20:00:58 +0000 (21:00 +0100)
Disable a few checks, and hard code the values for a few other items
to work around potential host contamination issues.  We also default
to the cups configuration for items.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb

index 96271875694e0ac0ff0814bd11666b023512b04a..e3bcf782ebe0b40fefb098f7dab5a49eb72ba36c 100644 (file)
@@ -10,7 +10,7 @@ format using a printer-specific, but spooler-independent PPD file. \
 "
 
 DEPENDS += "cups perl libxml2"
-PR = "r1"
+PR = "r2"
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
@@ -20,11 +20,20 @@ SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.
 SRC_URI[md5sum] = "20abd25c1c98b2dae68709062a132a7d"
 SRC_URI[sha256sum] = "090313fae40b177f505d9c9b93d7a4d7188b6d5d18b6ae41ab24903ac983478d"
 
-do_install_append_linuxstdbase() {
-    install -d ${D}${libdir}/cups/filter
-    ln -sf ${bindir}/foomatic-rip ${D}${libdir}/cups/filter
+inherit autotools
+
+EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
+
+do_configure_prepend() {
+    export LIB_CUPS=${exec_prefix}/lib/cups               # /usr/lib NOT libdir
+    export CUPS_BACKENDS=${exec_prefix}/lib/cups/backend  # /usr/lib NOT libdir
+    export CUPS_FILTERS=${exec_prefix}/lib/cups/filter    # /usr/lib NOT libdir
+    export CUPS_PPDS=${datadir}/cups/model
 }
 
-FILES_${PN}_append_linuxstdbase += "${libdir}/cups/filter/foomatic-rip"
+do_install_append_linuxstdbase() {
+    install -d ${D}${exec_prefix}/lib/cups/filter
+    ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
+}
 
-inherit autotools
+FILES_${PN}_append_linuxstdbase += "${exec_prefix}/lib/cups/filter/foomatic-rip"