]> code.ossystems Code Review - openembedded-core.git/commitdiff
classes/meta: Add DISTRO_FEATURES check for gtk+/gtk3+
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 28 Sep 2015 10:53:35 +0000 (11:53 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Sep 2015 14:15:47 +0000 (15:15 +0100)
If you currently do a DISTRO_FEATURES_remove = "x11" with OE-Core, you
see failures due to dependency problems. The work in resolving this was
partially completed a while back. This adds in the markup mainly for
gtk/gtk3+ recipes and means "bitbake world" will work successfully.

Rather than code the gtk/gtk+ specific distro features into each recipe,
a shared variable is used.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
21 files changed:
meta/conf/distro/include/default-distrovars.inc
meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb
meta/recipes-connectivity/connman/connman-gnome_0.7.bb
meta/recipes-devtools/python/python-pygtk_2.24.0.bb
meta/recipes-gnome/epiphany/epiphany_3.16.3.bb
meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb
meta/recipes-gnome/gtk+/gtk+.inc
meta/recipes-gnome/gtk+/gtk+3.inc
meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
meta/recipes-gnome/gtk-theme-torturer/gtk-theme-torturer_git.bb
meta/recipes-gnome/libglade/libglade_2.6.4.bb
meta/recipes-gnome/libwnck/libwnck3_3.14.0.bb
meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
meta/recipes-kernel/oprofile/oprofileui_git.bb
meta/recipes-kernel/sysprof/sysprof_git.bb
meta/recipes-kernel/trace-cmd/kernelshark_git.bb
meta/recipes-multimedia/gstreamer/gst-player_git.bb
meta/recipes-sato/gtk-engines/gtk-sato-engine.inc
meta/recipes-sato/matchbox-terminal/matchbox-terminal_git.bb
meta/recipes-support/libfm/libfm_1.2.3.bb
meta/recipes-support/vte/vte.inc

index 29b762b2273371cb0067ea1b8858f5669aa2cdc2..836690492b6aed1ff9e682d1d47f089a41c112b7 100644 (file)
@@ -47,3 +47,6 @@ DISTRO_VERSION ??= "nodistro.0"
 
 # Missing checksums should raise an error
 BB_STRICT_CHECKSUM = "1"
+
+GTK2DISTROFEATURES = "directfb x11"
+GTK3DISTROFEATURES = "x11 wayland"
index eea4d70fabf120cb8fcb44b145fd1adb6ac7e2e3..0d42b90e71379e50e423569e8c46871907d8dfef 100644 (file)
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
 
 require avahi.inc
 
-inherit python-dir pythonnative
+inherit python-dir pythonnative distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 PACKAGECONFIG ??= "python"
 PACKAGECONFIG[python] = "--enable-python,--disable-python,python-native python"
index f5575d29388cb07eecc1e1e14011d794be5bcf44..0fd1c65a3b8064ea4cb7eeef3c9c72384ae954fb 100644 (file)
@@ -19,7 +19,8 @@ SRC_URI = "git://github.com/connectivity/connman-gnome.git \
 
 S = "${WORKDIR}/git"
 
-inherit autotools-brokensep gtk-icon-cache pkgconfig
+inherit autotools-brokensep gtk-icon-cache pkgconfig distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 RDEPENDS_${PN} = "connman"
 
index e4c33a803f040130a2e6b6f7c6ee67c5b66a8a3f..79b3110e30f878f3e3b7ce2ad1bfe562e5e1679c 100644 (file)
@@ -26,7 +26,9 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
 
-inherit autotools pkgconfig distutils-base
+inherit autotools pkgconfig distutils-base distro_features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 do_configure_prepend() {
        install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
index 506fb25dd6a484277f1e2c597273551b5bf6337a..c3745c0ed1aa131e3095ee0af544e143e5032c9e 100644 (file)
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes ca-certificates avahi libnotify gcr libwnck3 \
           gsettings-desktop-schemas gnome-desktop3"
 
-inherit gnomebase gsettings
+inherit gnomebase gsettings distro_features_check
+# libwnck3 is x11 only
+REQUIRED_DISTRO_FEATURES = "x11"
+
 SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch"
 SRC_URI[archive.md5sum] = "3296af4532b8019775f4b40d21a341ae"
 SRC_URI[archive.sha256sum] = "d527f1770779ec22d955aeb13b148a846a26144e433ff0480c981af80e2390b1"
index 1f2f06c847609e60c9b4ce19def5d30929e7efe8..aa11fa28d9b940cc5002a5ad6f631c6343366520 100644 (file)
@@ -12,6 +12,9 @@ SRC_URI[archive.sha256sum] = "3a8f196b46eb9dbd3ba2afb8fb5fef6a8825539d449a021813
 
 DEPENDS += "gsettings-desktop-schemas gconf libxrandr virtual/libx11 gtk+3 glib-2.0 gnome-doc-utils gnome-common startup-notification iso-codes"
 
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
 EXTRA_OECONF = "--disable-desktop-docs"
 
 PACKAGES =+ "libgnome-desktop3"
index be5273d620cf6160ea09970d5893215caf8e0ae5..a197b9d96f9ed32bbaa47e0dcd27f88921bce283 100644 (file)
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
 SECTION = "libs"
 
 inherit distro_features_check
-ANY_OF_DISTRO_FEATURES = "directfb x11"
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 X11DEPENDS = "virtual/libx11 libxext libxcursor libxrandr libxdamage libxrender libxcomposite"
 DEPENDS = "glib-2.0 pango atk jpeg libpng gdk-pixbuf-native docbook-utils-native \
index f29f0d3031fa8cab6ddec8558e9b2712f7ff1215..558cdd7340348f72f848bd231e9f59f51963dc8d 100644 (file)
@@ -10,7 +10,8 @@ DEPENDS = "glib-2.0 cairo pango atk jpeg libpng gdk-pixbuf \
 
 LICENSE = "LGPLv2 & LGPLv2+ & LGPLv2.1+"
 
-inherit autotools pkgconfig gtk-doc update-alternatives gtk-immodules-cache gsettings
+inherit autotools pkgconfig gtk-doc update-alternatives gtk-immodules-cache gsettings distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
 # This should be in autotools.bbclass, but until something elses uses it putting
 # it here avoids rebuilding everything.
index c30454cab5479df1a09cda699254f04a265baaa0..95d5e554d6c3df6875d9f63f38417a52a75c5cc2 100644 (file)
@@ -34,6 +34,9 @@ RDEPENDS_${PN}-dev = ""
 inherit gnomebase
 GNOME_COMPRESS_TYPE="bz2"
 
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
 python populate_packages_prepend() {
     engines_root = os.path.join(d.getVar('libdir', True), "gtk-2.0/2.10.0/engines")
     themes_root = os.path.join(d.getVar('datadir', True), "themes")
index 889fd89417784602dbfe75305fa7fa730ecd4f79..b67806def959a34af4927a920c9e95c5e4d75e2f 100644 (file)
@@ -13,6 +13,9 @@ S = "${WORKDIR}/git/gtk-theme-torturer"
 
 CFLAGS += "-Wl,-rpath-link,${STAGING_LIBDIR}"
 
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 torturer ${D}${bindir}
index 15267cad87d61239b8644444ca110a61023b2cc8..553e19c601057df53ae3c983381802843b896542 100644 (file)
@@ -11,7 +11,8 @@ SECTION = "libs"
 PR = "r5"
 DEPENDS = "zlib gdk-pixbuf gtk+"
 
-inherit autotools pkgconfig gnomebase gtk-doc
+inherit autotools pkgconfig gnomebase gtk-doc distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 GNOME_COMPRESS_TYPE="bz2"
 
 SRC_URI += "file://glade-cruft.patch file://no-xml2.patch file://python_environment.patch"
index d0f5175e5d09fd3bdcd88dcfab3cd5446f3b2464..3ee1ae98a48471688b009a50d6acbf4bc0353608 100644 (file)
@@ -13,3 +13,8 @@ PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-s
 inherit gnomebase
 SRC_URI[archive.md5sum] = "4538672e0d775fadedf10abeb8020047"
 SRC_URI[archive.sha256sum] = "f5080076346609b4c36394b879f3a86b92ced3b90a37cb54c8e9a14f00e7921c"
+
+inherit distro_features_check
+# libxres means x11 only
+REQUIRED_DISTRO_FEATURES = "x11"
+
index cc1c02b5536b0ef18f957f55685f869a67738540..9881c942b877a6cd00132bca96ee75325ff44b02 100644 (file)
@@ -23,6 +23,9 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
 
 inherit autotools pkgconfig
 
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
 PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86vidmodeproto compositeproto recordproto resourceproto videoproto scrnsaverproto  xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto presentproto"
 LIB_DEPS = "pixman libxfont xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess openssl libgcrypt"
 DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} font-util"
index bb69d5404daa49c75efa0e447eb1bbd4b9afbb90..8fad09966459fc35b67651b4a47f1ac17f30f056 100644 (file)
@@ -2,6 +2,9 @@ require oprofileui.inc
 
 DEPENDS += "gtk+ libglade libxml2 avahi-ui gconf"
 
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
 SRCREV = "389e1875af4721d52c7e65cf9cfffb69b0ed6a59"
 PV = "0.0+git${SRCPV}"
 
index 19c3e10f7c72c0fda9086d10e76ba8e2ee1434d7..7d87efe7db8aaf4a15a7046793f92b786679f2fa 100644 (file)
@@ -19,7 +19,8 @@ SRC_URI_append_mips64n32 = " file://rmb-mips.patch"
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 # We do not yet work for aarch64.
 #
index 9deccaefd9ab84cf126e5ee77b51a592cd22d711..563182c89feb84fca5376281186236e17b224248 100644 (file)
@@ -9,6 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
 DEPENDS = "gtk+ libxml2"
 RDEPENDS_${PN} = "trace-cmd"
 
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
 EXTRA_OEMAKE = "\
     'prefix=${prefix}' \
     'bindir_relative=${@oe.path.relative(prefix, bindir)}' \
index 54cfbbc9279ffec4d92c305718577d96efee8729..9850242567bbf7b4ce7e4aa65118577979bc6e5b 100644 (file)
@@ -16,7 +16,9 @@ SRCREV = "5386c5b984d40ef5434673ed62204e69aaf52645"
 
 S = "${WORKDIR}/git"
 
-inherit autotools gtk-doc lib_package pkgconfig
+inherit autotools gtk-doc lib_package pkgconfig distro_features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 do_configure_prepend() {
        touch ${S}/ChangeLog
index 4e37ff20470ab6f62e8487063c58116725010a75..fa6b2b2e7560ff1bf3a3eb73b2fdf0cc2ca19a67 100644 (file)
@@ -8,6 +8,9 @@ SECTION = "x11/base"
 DEPENDS = "gtk+"
 RDEPENDS_gtk-theme-sato = "gtk-sato-engine"
 
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
 PACKAGES += "gtk-theme-sato"
 FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so "
 FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*.la"
index 91fd150e3b17f9c9e538042349f70dfdca60bc75..c8cbd57a6eefd06f172d892c6474a72358090e51 100644 (file)
@@ -15,4 +15,6 @@ SRC_URI = "git://git.yoctoproject.org/${BPN}"
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
index 629502f68fafacaebc80c0a05c215b60c77b0e89..b225232f39d21b380ffd164a95c28c28d99e8e7f 100644 (file)
@@ -18,7 +18,8 @@ SRC_URI[sha256sum] = "c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344
 
 PR = "r1"
 
-inherit autotools pkgconfig gtk-doc
+inherit autotools pkgconfig gtk-doc distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 do_configure[dirs] =+ "${S}/m4"
 
index 874062adbe06e35b7c20a0ee4b6b116320633bac..07b9e10dce58b13a4659cd5bef90bd96bd1384e0 100644 (file)
@@ -4,7 +4,8 @@ LICENSE = "LGPLv2.0"
 DEPENDS = " glib-2.0 gtk+ intltool-native ncurses gobject-introspection-stub"
 RDEPENDS_libvte = "vte-termcap"
 
-inherit gnome gtk-doc
+inherit gnome gtk-doc distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
 
 EXTRA_OECONF = "--disable-python --disable-introspection"