]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-wrs: Change the kernel configuration to enable psplash.
authorKevin Tian <kevin.tian@intel.com>
Sat, 9 Oct 2010 05:00:28 +0000 (13:00 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 11:25:53 +0000 (12:25 +0100)
Init scripts assume uvesafb as module, and also need CONFIG_FRAMEBUFFER_CONSOLE
to set some mode parameter, else wrong parameter cause psplash's mmap failure.

This is just a quick fix as we don't know how to change the wrs kernel config
in a clean way. Should revert it with clean way of changing.

[BUGID #363] fixed by this

Signed-off-by: Tian Kevin <kevin.tian@intel.com>
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/recipes-kernel/linux/linux-wrs_git.bb
meta/recipes-kernel/linux/x86-wrs.cfg [new file with mode: 0644]

index 65bb93c74ed451ab4d80929233bf497646d55114..f6b0aead55c86a6744049c0a60955dabb5a2f263 100644 (file)
@@ -16,6 +16,8 @@ SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclon
 SRC_URI_append_atom-pc = "\
            file://i915.cfg \
            file://8250.cfg"
+SRC_URI_append_qemux86 = " file://x86-wrs.cfg"
+SRC_URI_append_qemux86-64 = " file://x86-wrs.cfg"
            
 WRMACHINE = "${MACHINE}"
 WRMACHINE_qemux86  = "common_pc"
diff --git a/meta/recipes-kernel/linux/x86-wrs.cfg b/meta/recipes-kernel/linux/x86-wrs.cfg
new file mode 100644 (file)
index 0000000..da4f00a
--- /dev/null
@@ -0,0 +1,2 @@
+CONFIG_FB_UVESA=m
+CONFIG_FRAMEBUFFER_CONSOLE=y