]> code.ossystems Code Review - openembedded-core.git/commitdiff
fix nativesdk
authorRoss Burton <ross.burton@arm.com>
Mon, 4 Jan 2021 20:46:13 +0000 (20:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Feb 2021 23:46:49 +0000 (23:46 +0000)
meta/recipes-devtools/autoconf/autoconf.inc
meta/recipes-devtools/autoconf/autoconf/from-master.patch
meta/recipes-devtools/autoconf/autoconf/man-host-perl.patch [new file with mode: 0644]
meta/recipes-devtools/autoconf/autoconf_2.70.bb

index c7d7a2f74b52f39753d0026d898022d54906d77a..03e4ca8a3ed5da57f0eebc75ada381d824af645b 100644 (file)
@@ -6,8 +6,8 @@ LICENSE = "GPLv3"
 HOMEPAGE = "http://www.gnu.org/software/autoconf/"
 SECTION = "devel"
 
-DEPENDS = "m4-native gnu-config-native help2man-native"
-DEPENDS_remove_class-native = "help2man-native"
+DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native"
+DEPENDS_remove_class-native = "autoconf-native automake-native help2man-native"
 
 RDEPENDS_${PN} = "m4 gnu-config \
                  perl \
@@ -44,8 +44,8 @@ PERL_class-nativesdk = "/usr/bin/env perl"
 
 CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
 
-do_configure() {
-       # manually install a newer config.guess/.sub
+do_configure_class-native() {
+       # To bootstrap we need to do things manually
        install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
        install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
 
index 2a331961a6defafa5a0c227d7cb0b866c4def2ea..22ca744598b1383354289216d4d8a002db0a8b78 100644 (file)
@@ -1,81 +1,3 @@
-From 29ed3a774de200dd064c7997293b2cfd134ce5c4 Mon Sep 17 00:00:00 2001
-From: Zack Weinberg <zackw@panix.com>
-Date: Tue, 8 Dec 2020 13:04:16 -0500
-Subject: [PATCH 01/13] maint: post-release administrivia
-
-* NEWS: Add header line for next release.
-* .prev-version: Record previous version.
-* cfg.mk (old_NEWS_hash): Auto-update.
----
- .prev-version | 2 +-
- NEWS          | 3 +++
- cfg.mk        | 2 +-
- 3 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/.prev-version b/.prev-version
-index 5e1b8b06..587cb39c 100644
---- a/.prev-version
-+++ b/.prev-version
-@@ -1 +1 @@
--2.69
-+2.70
-diff --git a/NEWS b/NEWS
-index ba418d1a..2a4db5f6 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,5 +1,8 @@
- GNU Autoconf NEWS - User visible changes.
-+* Noteworthy changes in release ?.? (????-??-??) [?]
-+
-+
- * Noteworthy changes in release 2.70 (2020-12-08) [stable]
- ** Backward incompatibilities:
-diff --git a/cfg.mk b/cfg.mk
-index 33ad6e06..a15974bf 100644
---- a/cfg.mk
-+++ b/cfg.mk
-@@ -84,7 +84,7 @@ update-release-year:
- .PHONY: update-release-year
- # Prevent incorrect NEWS edits.
--old_NEWS_hash = b6af714b06666cbc66cd26169a56bd9d
-+old_NEWS_hash = 152f03614545887231fddaf67821b4d4
- exclude_file_name_regexp--sc_prohibit_undesirable_word_seq = \
-   ^(maint\.mk|build-aux/texinfo\.tex)$$
--- 
-2.25.1
-
-
-From b693e208691c54fbe07cdf49b9a98358baadcfe2 Mon Sep 17 00:00:00 2001
-From: Zack Weinberg <zackw@panix.com>
-Date: Tue, 8 Dec 2020 21:47:13 -0500
-Subject: [PATCH 02/13] maint: add outline for future NEWS (release branch).
-
----
- NEWS | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/NEWS b/NEWS
-index 2a4db5f6..56ad10f2 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,7 +1,8 @@
- GNU Autoconf NEWS - User visible changes.
--* Noteworthy changes in release ?.? (????-??-??) [?]
-+* Noteworthy changes in release 2.70.1 (????-??-??) [?]
-+** Bug fixes.
- * Noteworthy changes in release 2.70 (2020-12-08) [stable]
--- 
-2.25.1
-
-
 From efc940dc82763b7b2d6e65f04d15d5972d829c0a Mon Sep 17 00:00:00 2001
 From: Zack Weinberg <zackw@panix.com>
 Date: Tue, 8 Dec 2020 21:35:45 -0500
@@ -784,118 +706,6 @@ index ac7fe013..d449ce00 100644
 2.25.1
 
 
-From 08bb0fe5b409a4cd86620f114f4366e62b76ef49 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Tue, 29 Dec 2020 22:48:02 -0800
-Subject: [PATCH 10/13] doc: modernize grep discussion
-
----
- doc/autoconf.texi | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/doc/autoconf.texi b/doc/autoconf.texi
-index 5e17280e..d09aba70 100644
---- a/doc/autoconf.texi
-+++ b/doc/autoconf.texi
-@@ -19291,8 +19291,8 @@ dir=`AS_DIRNAME(["$file"])` # This is more portable.
- @item @command{egrep}
- @c ------------------
- @prindex @command{egrep}
--Posix 1003.1-2001 no longer requires @command{egrep},
--but many hosts do not yet support the Posix
-+Although Posix stopped requiring @command{egrep} in 2001,
-+a few traditional hosts (notably Solaris) do not support the Posix
- replacement @code{grep -E}.  Also, some traditional implementations do
- not work on long input lines.  To work around these problems, invoke
- @code{AC_PROG_EGREP} and then use @code{$EGREP}.
-@@ -19477,8 +19477,8 @@ expr: More than one '\(' was used.
- @item @command{fgrep}
- @c ------------------
- @prindex @command{fgrep}
--Posix 1003.1-2001 no longer requires @command{fgrep},
--but many hosts do not yet support the Posix
-+Although Posix stopped requiring @command{fgrep} in 2001,
-+a few traditional hosts (notably Solaris) do not support the Posix
- replacement @code{grep -F}.  Also, some traditional implementations do
- not work on long input lines.  To work around these problems, invoke
- @code{AC_PROG_FGREP} and then use @code{$FGREP}.
-@@ -19519,7 +19519,7 @@ portable scripts should not combine @option{-c} with @option{-l},
- as Posix does not allow this.
- Some of the options required by Posix are not portable in practice.
--Don't use @samp{grep -q} to suppress output, because many @command{grep}
-+Don't use @samp{grep -q} to suppress output, because traditional @command{grep}
- implementations (e.g., Solaris) do not support @option{-q}.
- Don't use @samp{grep -s} to suppress output either, because Posix
- says @option{-s} does not suppress output, only some error messages;
-@@ -19537,7 +19537,7 @@ Some traditional @command{grep} implementations do not work on long
- input lines.  On AIX the default @code{grep} silently truncates long
- lines on the input before matching.
--Also, many implementations do not support multiple regexps
-+Also, traditional implementations do not support multiple regexps
- with @option{-e}: they either reject @option{-e} entirely (e.g., Solaris)
- or honor only the last pattern (e.g., IRIX 6.5 and NeXT).  To
- work around these problems, invoke @code{AC_PROG_GREP} and then use
--- 
-2.25.1
-
-
-From ec2aa28b6427274b214c244d05b32bc4d7e865cd Mon Sep 17 00:00:00 2001
-From: Bruno Haible <bruno@clisp.org>
-Date: Wed, 30 Dec 2020 10:21:48 -0500
-Subject: [PATCH 11/13] doc: Document another portability problem of 'od'.
-
-* doc/autoconf.texi (Limitations of Usual Tools): Document that decimal output
-is not portable.
----
- doc/autoconf.texi | 23 +++++++++++++++++++++--
- 1 file changed, 21 insertions(+), 2 deletions(-)
-
-diff --git a/doc/autoconf.texi b/doc/autoconf.texi
-index d09aba70..db1e0f46 100644
---- a/doc/autoconf.texi
-+++ b/doc/autoconf.texi
-@@ -19782,14 +19782,33 @@ perfectly portable among Posix hosts.
- @c ---------------
- @prindex @command{od}
--In Mac OS X 10.3, @command{od} does not support the
-+In MacOS X versions prior to 10.4.3, @command{od} does not support the
- standard Posix options @option{-A}, @option{-j}, @option{-N}, or
- @option{-t}, or the XSI option, @option{-s}.  The only
- supported Posix option is @option{-v}, and the only supported
- XSI options are those in @option{-bcdox}.  The BSD
- @command{hexdump} program can be used instead.
--This problem no longer exists in Mac OS X 10.4.3.
-+In some versions of some operating systems derived from Solaris 11,
-+@command{od} prints decimal byte values padded with zeroes rather than
-+with spaces:
-+
-+@smallexample
-+$ @kbd{printf '#!' | od -A n -t d1 -N 2}
-+         035 033
-+@end smallexample
-+
-+@noindent
-+instead of
-+
-+@smallexample
-+$ @kbd{printf '#!' | od -A n -t d1 -N 2}
-+          35  33
-+@end smallexample
-+
-+We have observed this on both OpenIndiana and OmniOS;
-+Illumos may also be affected.
-+As a workaround, you can use octal output (option @code{-t o1}).
- @item @command{rm}
--- 
-2.25.1
-
-
 From fac6e5e5cf5b974dda2b82d6331d9dcb4b3e0016 Mon Sep 17 00:00:00 2001
 From: Zack Weinberg <zackw@panix.com>
 Date: Mon, 21 Dec 2020 14:04:22 -0500
diff --git a/meta/recipes-devtools/autoconf/autoconf/man-host-perl.patch b/meta/recipes-devtools/autoconf/autoconf/man-host-perl.patch
new file mode 100644 (file)
index 0000000..c6c1356
--- /dev/null
@@ -0,0 +1,24 @@
+Don't use the target perl when regenerating the man pages.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+diff --git a/man/local.mk b/man/local.mk
+index e69858b1..78c68ab5 100644
+--- a/man/local.mk
++++ b/man/local.mk
+@@ -67,13 +67,12 @@ SUFFIXES += .w .1
+       @echo "Updating man page $@"
+       $(MKDIR_P) $(@D)
+       PATH="$(top_srcdir)/man$(PATH_SEPARATOR)$$PATH"; \
+-      PERL="$(PERL)"; \
+       PACKAGE_NAME="$(PACKAGE_NAME)"; \
+       VERSION="$(VERSION)"; \
+       RELEASE_YEAR="$(RELEASE_YEAR)"; \
+       top_srcdir="$(top_srcdir)"; \
+       channeldefs_pm="$(channeldefs_pm)"; \
+-      export PATH PERL PACKAGE_NAME VERSION RELEASE_YEAR; \
++      export PATH PACKAGE_NAME VERSION RELEASE_YEAR; \
+       export top_srcdir channeldefs_pm; \
+       $(HELP2MAN) \
+           --include=$(srcdir)/$*.x \
index d6f543545eec9ea0eb6c7faed1d23c9ae44cf13c..d41b91bb325981712edc6104dc19d4543bbf41fc 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "${GNU_MIRROR}/autoconf/${BP}.tar.gz \
            file://remove-usr-local-lib-from-m4.patch \
            file://preferbash.patch \
            file://autotest-automake-result-format.patch \
+           file://man-host-perl.patch \
            "
 
 SRC_URI[sha256sum] = "f05f410fda74323ada4bdc4610db37f8dbd556602ba65bc843edb4d4d4a1b2b7"