]> code.ossystems Code Review - openembedded-core.git/commitdiff
devtool: make required tasks be run in kernel build
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>
Tue, 18 Aug 2015 14:13:12 +0000 (17:13 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Sep 2015 12:32:34 +0000 (13:32 +0100)
Set SRCTREECOVEREDTASKS appropriately in the workspace .bbappend file
for kernel recipes. This tries to ensure that all needed tasks (esp.
configure and patch) are run when building the kernel - tasks which
would normally be disabled by externalsrc.bbclass.

[YOCTO #6658]

Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
scripts/lib/devtool/standard.py

index de7afd97c2b3aaaaf77eb76ef22758f6e5b74773..6ba86ed80161d6d2c0e67a7d510d3e5fac9c0f32 100644 (file)
@@ -473,6 +473,8 @@ def modify(args, config, basepath, workspace):
         if b_is_s:
             f.write('EXTERNALSRC_BUILD_pn-%s = "%s"\n' % (args.recipename, srctree))
 
+        if bb.data.inherits_class('kernel', rd):
+            f.write('SRCTREECOVEREDTASKS = "do_validate_branches do_kernel_checkout do_shared_workdir do_fetch do_unpack"\n')
         if initial_rev:
             f.write('\n# initial_rev: %s\n' % initial_rev)
             for commit in commits: