]> code.ossystems Code Review - openembedded-core.git/commitdiff
ovmf-shell-image.bb: simplify dependencies
authorPatrick Ohly <patrick.ohly@intel.com>
Fri, 21 Jul 2017 06:25:13 +0000 (08:25 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 24 Jul 2017 08:12:28 +0000 (09:12 +0100)
The image consists only of the EFI system partition, therefore
we can avoid depending on the default wic tools.

Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/ovmf/ovmf-shell-image.bb

index 029547b94aa365bcf8bc79feceb90d89ae1e932b..0d2b8bf52ff3185171f4c85e46a7c37b498ef2db 100644 (file)
@@ -1,10 +1,13 @@
 DESCRIPTION = "boot image with UEFI shell and tools"
 
 # For this image recipe, only the wic format with a
-# single vfat partition makes sense.
+# single vfat partition makes sense. Because we have no
+# boot loader and no rootfs partition, not additional
+# tools are needed for this .wks file.
 IMAGE_FSTYPES_forcevariable = 'wic'
-
 WKS_FILE = "ovmf/ovmf-shell-image.wks"
+WKS_FILE_DEPENDS = ""
+
 inherit image
 
 # We want a minimal image with just ovmf-shell-efi unpacked in it. We