]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxslt: create wrapper to avoid host system referencing
authorChen Qi <Qi.Chen@windriver.com>
Sun, 30 Nov 2014 08:46:37 +0000 (16:46 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Dec 2014 17:42:45 +0000 (17:42 +0000)
By default, xsltproc from libxslt would use configuration files under
/etc/xml. To avoid host system contamination, we create a wrapper for
this command to make it use configuration files in the sysroot directory.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libxslt/libxslt_1.1.28.bb

index 0b2526dbeee7786d3c49340ce8e12b1a1af59001..ded883e457caba46d13993c11af47516da009924 100644 (file)
@@ -35,6 +35,11 @@ RPROVIDES_${PN}-bin += "${PN}-utils"
 RCONFLICTS_${PN}-bin += "${PN}-utils"
 RREPLACES_${PN}-bin += "${PN}-utils"
 
+
+do_install_append_class-native () {
+    create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
+}
+
 FILES_${PN} += "${libdir}/libxslt-plugins"
 FILES_${PN}-dev += "${libdir}/xsltConf.sh"