]> code.ossystems Code Review - openembedded-core.git/commitdiff
opensbi: Update to OpenSBI v0.8 release
authorAlistair Francis <alistair.francis@wdc.com>
Wed, 24 Jun 2020 19:27:50 +0000 (12:27 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Jun 2020 07:23:12 +0000 (08:23 +0100)
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/machine/include/riscv/qemuriscv.inc
meta/recipes-bsp/opensbi/opensbi_0.8.bb [moved from meta/recipes-bsp/opensbi/opensbi_0.6.bb with 65% similarity]

index a42346f361c6098ed16aed5dedb743cbea5d286a..759c8a196eb96293e402580fbd54f55df8738c2a 100644 (file)
@@ -18,7 +18,7 @@ WKS_FILE ?= "qemuriscv.wks"
 MACHINE_EXTRA_RRECOMMENDS += " kernel-modules"
 
 EXTRA_IMAGEDEPENDS += "opensbi"
-RISCV_SBI_PLAT ?= "qemu/virt"
+RISCV_SBI_PLAT ?= "generic"
 RISCV_SBI_PAYLOAD ?= "${KERNEL_IMAGETYPE}-${MACHINE}.bin"
 
 UBOOT_ENTRYPOINT_riscv32 = "0x80400000"
similarity index 65%
rename from meta/recipes-bsp/opensbi/opensbi_0.6.bb
rename to meta/recipes-bsp/opensbi/opensbi_0.8.bb
index 56f2d4b91516f5c88f376b1bb5c42f23fed2380d..818efac73384138afd18bb4f3a4e69e27a4b29a9 100644 (file)
@@ -7,8 +7,8 @@ require opensbi-payloads.inc
 
 inherit autotools-brokensep deploy
 
-SRCREV = "ac5e821d50be631f26274765a59bc1b444ffd862"
-SRC_URI = "git://github.com/riscv/opensbi.git \
+SRCREV = "a98258d0b537a295f517bbc8d813007336731fa9"
+SRC_URI = "git://github.com/riscv/opensbi.git;branch=master \
            file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
           "
 
@@ -25,22 +25,21 @@ do_install_append() {
        # In the future these might be required as a dependency for other packages.
        # At the moment just delete them to avoid warnings
        rm -r ${D}/include
-       rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib
-       rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads
-       rm -r ${D}/lib
+       rm -r ${D}/lib*
+       rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
 }
 
 do_deploy () {
-       install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
-       install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
-       install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
+       install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
+       install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
+       install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
 }
 
 addtask deploy before do_build after do_install
 
-FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
-FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
-FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
+FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
+FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
+FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
 
 COMPATIBLE_HOST = "(riscv64|riscv32).*"
 INHIBIT_PACKAGE_STRIP = "1"