]> code.ossystems Code Review - openembedded-core.git/commitdiff
libiconv: Fix build failure on 1.13.1
authorKhem Raj <raj.khem@gmail.com>
Thu, 21 Jul 2011 21:23:22 +0000 (14:23 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Jul 2011 21:50:06 +0000 (22:50 +0100)
It needs a different patch for 1.13.1 for autoconf'ing
Rename files to libiconv-1.11.1 and have a separate
directory for libiconv-1.13.1

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libiconv/libiconv-1.11.1/autoconf.patch [moved from meta/recipes-support/libiconv/files/autoconf.patch with 100% similarity]
meta/recipes-support/libiconv/libiconv-1.11.1/shared_preloadable_libiconv_linux.patch [moved from meta/recipes-support/libiconv/files/shared_preloadable_libiconv_linux.patch with 100% similarity]
meta/recipes-support/libiconv/libiconv-1.13.1/autoconf.patch [new file with mode: 0644]
meta/recipes-support/libiconv/libiconv_1.13.1.bb

diff --git a/meta/recipes-support/libiconv/libiconv-1.13.1/autoconf.patch b/meta/recipes-support/libiconv/libiconv-1.13.1/autoconf.patch
new file mode 100644 (file)
index 0000000..5d34ce7
--- /dev/null
@@ -0,0 +1,50 @@
+It adds the variables that are needed
+for autoconf 2.65 to reconfigure libiconv and delete the m4 macros
+directory. Its imported from OE.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libiconv-1.13.1/configure.ac
+===================================================================
+--- libiconv-1.13.1.orig/configure.ac
++++ libiconv-1.13.1/configure.ac
+@@ -23,7 +23,7 @@ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([libiconv], [1.13.1])
+ AC_CONFIG_HEADERS([config.h lib/config.h])
+ AC_PROG_MAKE_SET
+-
++AC_CONFIG_MACRO_DIR([m4])
+ dnl           checks for basic programs
+ AC_PROG_CC
+Index: libiconv-1.13.1/libcharset/configure.ac
+===================================================================
+--- libiconv-1.13.1.orig/libcharset/configure.ac
++++ libiconv-1.13.1/libcharset/configure.ac
+@@ -16,17 +16,17 @@ dnl along with the GNU CHARSET Library;
+ dnl write to the Free Software Foundation, Inc., 51 Franklin Street,
+ dnl Fifth Floor, Boston, MA 02110-1301, USA.
+-AC_PREREQ([2.13])
++AC_PREREQ(2.61)
++AC_INIT([libcharset],[1.4] )
++AC_CONFIG_SRCDIR([lib/localcharset.c])
+-PACKAGE=libcharset
+-VERSION=1.4
+-
+-AC_INIT([lib/localcharset.c])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_CONFIG_HEADER([config.h])
+ AC_PROG_MAKE_SET
+-AC_SUBST([PACKAGE])
+-AC_SUBST([VERSION])
++dnl AC_SUBST(PACKAGE)
++dnl AC_SUBST(VERSION)
++
++AC_CONFIG_MACRO_DIR([m4])
+ dnl           checks for basic programs
index 026f53010715324137a3544e0f10e173e7df64a8..6471e32d5bc458fa54841acf8ef640f9428aea44 100644 (file)
@@ -11,7 +11,6 @@ LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674 \
 
 SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
            file://autoconf.patch \
-          file://shared_preloadable_libiconv_linux.patch \
           "
 
 SRC_URI[md5sum] = "7ab33ebd26687c744a37264a330bbe9a"
@@ -26,5 +25,5 @@ EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
 LEAD_SONAME = "libiconv.so"
 
 do_configure_prepend () {
-       rm -f m4/libtool.m4 libcharset/m4/libtool.m4
+       rm -f m4/libtool.m4 m4/ltoptions.m4 m4/ltsugar.m4 m4/ltversion.m4 m4/lt~obsolete.m4 libcharset/m4/libtool.m4 libcharset/m4/ltoptions.m4 libcharset/m4/ltsugar.m4 libcharset/m4/ltversion.m4 libcharset/m4/lt~obsolete.m4
 }