]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-toolchain: Change to be more generic and use package_ipk conf generation functio...
authorRichard Purdie <richard@openedhand.com>
Sat, 1 Sep 2007 22:49:32 +0000 (22:49 +0000)
committerRichard Purdie <richard@openedhand.com>
Sat, 1 Sep 2007 22:49:32 +0000 (22:49 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2638 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/meta-toolchain.bb
meta/packages/tasks/task-sdk-host.bb [moved from meta/packages/tasks/task-poky-standalone-sdk-host.bb with 68% similarity]

index a0f38404b0af840accc9a36fe933b38db341e9c5..36c1479b68817c8f64a01faa8f09ed6de5892fb5 100644 (file)
@@ -11,33 +11,27 @@ SDK_DEPLOY = "${TMPDIR}/deploy/sdk"
 IPKG_HOST = "ipkg-cl -f ${IPKGCONF_SDK} -o ${SDK_OUTPUT}"
 IPKG_TARGET = "ipkg-cl -f ${IPKGCONF_TARGET} -o ${SDK_OUTPUT}/${prefix}"
 
-HOST_INSTALL = "task-poky-standalone-sdk-host"
+TOOLCHAIN_HOST_TASK ?= "task-sdk-host"
+TOOLCHAIN_TARGET_TASK ?= "task-poky-standalone-sdk-target"
 
-TARGET_INSTALL = "task-poky-standalone-sdk-target"
-
-RDEPENDS = "${TARGET_INSTALL} ${HOST_INSTALL}"
+RDEPENDS = "${TOOLCHAIN_TARGET_TASK} ${TOOLCHAIN_HOST_TASK}"
 
 do_populate_sdk() {
-       touch ${DEPLOY_DIR_IPK}/Packages
-       ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
-
        rm -rf ${SDK_OUTPUT}
        mkdir -p ${SDK_OUTPUT}
 
+       package_update_index_ipk
        package_generate_ipkg_conf
 
        for arch in ${PACKAGE_ARCHS}; do
                revipkgarchs="$arch $revipkgarchs"
        done
 
-       rm -r ${SDK_OUTPUT}
-       mkdir -p ${SDK_OUTPUT}
-
        ${IPKG_HOST} update
-       ${IPKG_HOST} -force-depends install ${HOST_INSTALL}
+       ${IPKG_HOST} -force-depends install ${TOOLCHAIN_HOST_TASK}
 
        ${IPKG_TARGET} update
-       ${IPKG_TARGET} install ${TARGET_INSTALL}
+       ${IPKG_TARGET} install ${TOOLCHAIN_TARGET_TASK}
 
        mkdir -p ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}
        cp -pPR ${SDK_OUTPUT}/${prefix}/usr/* ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}
similarity index 68%
rename from meta/packages/tasks/task-poky-standalone-sdk-host.bb
rename to meta/packages/tasks/task-sdk-host.bb
index a8beb054ad790acb4c5f0ea1f34859ec982ae01c..d238b46144b55c3bcd10246c8096e126e9d9cbd7 100644 (file)
@@ -1,4 +1,8 @@
-DESCRIPTION = "Host packages for the standalone SDK (external toolchain)"
+#
+# Copyright (C) 2007 OpenedHand Ltd
+#
+
+DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
 PR = "r1"
 LICENSE = "MIT"
 ALLOW_EMPTY = "1"