]> code.ossystems Code Review - openembedded-core.git/commitdiff
libgpg-error: Support build for native on ppc64/ppc64le hosts
authorSerhey Popovych <serhe.popovych@gmail.com>
Thu, 1 Nov 2018 17:21:10 +0000 (19:21 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Nov 2018 12:14:05 +0000 (12:14 +0000)
Both RHEL and SLES uses ppc64/ppc64le for powerpc 64 bit big/little
endian targets instead of powerpc64/powerpc64le in libgpg-error.

Also libgpg-error provides common target system names in form like
<arch>-unknown-linux-gnu.

Add mapping for ppc64/ppc64le targets to their libgpg-error equivalents
to fix native builds.

Cross build for arm64 tested on IBM Power 8 machine with RHEL7 for
ppc64le variant only, but should work for ppc64 as well.

Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libgpg-error/libgpg-error_1.32.bb

index a6ca982c0ee514ce1c4fb054ea6fe5f8b91bcd14..e552001cb6382766b160e08dac1b26193d58d13a 100644 (file)
@@ -48,6 +48,8 @@ do_compile_prepend() {
          mips*el)    TUPLE=mipsel-unknown-linux-gnu ;;
          mips*)      TUPLE=mips-unknown-linux-gnu ;;
          x86_64)     TUPLE=x86_64-unknown-linux-gnu ;;
+         ppc64)      TUPLE=powerpc64-unknown-linux-gnu ;;
+         ppc64le)    TUPLE=powerpc64le-unknown-linux-gnu ;;
          *)          TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
        esac