]> code.ossystems Code Review - openembedded-core.git/commitdiff
gummiboot: add COMPATIBLE_HOST
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 27 Mar 2014 06:13:58 +0000 (14:13 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 Mar 2014 15:44:16 +0000 (15:44 +0000)
The gummiboot depends on gnu-efi which had set:

COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"

We also need set this for gummiboot, otherwise there would be build
failures for other non-x86 archs.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-bsp/gummiboot/gummiboot_git.bb

index 5868a23ae877bf54e47e5730d647a36a263566a1..035cec163ced5c8bb3b20c03c3078d77fb8ec046 100644 (file)
@@ -13,6 +13,11 @@ PV = "43+git${SRCPV}"
 SRCREV = "4062c51075ba054d4949c714fe06123f9ad3097d"
 SRC_URI = "git://anongit.freedesktop.org/gummiboot"
 
+# Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi
+# which has set the COMPATIBLE_HOST, the gummiboot itself may work on
+# more hosts.
+COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
+
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \