]> code.ossystems Code Review - openembedded-core.git/commitdiff
procps: raise update-alternatives priority
authorKoen Kooi <koen@dominion.thruhere.net>
Sat, 31 Dec 2011 16:04:56 +0000 (17:04 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Jan 2012 12:10:48 +0000 (12:10 +0000)
This fixes a problem with the uptime utility:

root@beagleboneA3-0088:/var/lib/cloud9# busybox uptime
 16:00:17 up 2 days,  6:46,  load average: 0.14, 0.04, 0.05
root@beagleboneA3-0088:/var/lib/cloud9# uptime.procps
 16:00:22 up 2 days,  6:46,  1 user,  load average: 0.14, 0.05, 0.06
root@beagleboneA3-0088:/var/lib/cloud9# uptime.coreutils
 16:00pm  up 4382 days 15:58,  1 user,  load average: 0.13, 0.05, 0.05
root@beagleboneA3-0088:/var/lib/cloud9# ls /usr/bin/uptime -la
lrwxrwxrwx 1 root root 16 Dec 26 08:56 /usr/bin/uptime -> uptime.coreutils

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-extended/procps/procps_3.2.8.bb

index d989955f629b97c79ad15184a4cff701886cf526..6a41ccdef931d79df08c158972490dd5461b1a9b 100644 (file)
@@ -1,12 +1,12 @@
 require procps.inc
 
-PR = "r3"
+PR = "r4"
 
 inherit update-alternatives
 
 ALTERNATIVE_LINKS = "${bindir}/top ${bindir}/uptime ${bindir}/free ${bindir}/pkill ${bindir}/pmap \
                      ${base_bindir}/kill ${base_sbindir}/sysctl ${base_bindir}/ps"
-ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_PRIORITY = "110"
 
 SRC_URI += "file://procmodule.patch \
             file://psmodule.patch \