]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: Minor upgrade 3.5.0 -> 3.5.1
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Tue, 19 Jan 2016 21:56:32 +0000 (21:56 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jan 2016 09:20:04 +0000 (09:20 +0000)
Rebased:
- 000-cross-compile.patch

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-native_3.5.1.bb [moved from meta/recipes-devtools/python/python3-native_3.5.0.bb with 94% similarity]
meta/recipes-devtools/python/python3/000-cross-compile.patch
meta/recipes-devtools/python/python3_3.5.1.bb [moved from meta/recipes-devtools/python/python3_3.5.0.bb with 98% similarity]

similarity index 94%
rename from meta/recipes-devtools/python/python3-native_3.5.0.bb
rename to meta/recipes-devtools/python/python3-native_3.5.1.bb
index 0dd165019f1a8f51930957e43f19331566aca2df..152da1c5e24581d2c173282ed744cf862bc70191 100644 (file)
@@ -26,8 +26,8 @@ ${DISTRO_SRC_URI} \
 file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
 file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
 "
-SRC_URI[md5sum] = "d149d2812f10cbe04c042232e7964171"
-SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2e2be91" 
+SRC_URI[md5sum] = "e9ea6f2623fffcdd871b7b19113fde80"
+SRC_URI[sha256sum] = "c6d57c0c366d9060ab6c0cdf889ebf3d92711d466cc0119c441dbf2746f725c9"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
 
index a3ffe3bea88c080a7f2517335f2d75b3e6e0216b..28fe70adb384ced23c5a00e2483ad13db3a638d8 100644 (file)
@@ -9,11 +9,11 @@ Upstream-Status: Inappropriate[Configuration Specific]
  Makefile.pre.in |   25 +++++++++++++------------
  1 file changed, 13 insertions(+), 12 deletions(-)
 
-Index: Python-3.5.0/Makefile.pre.in
+Index: Python-3.5.1/Makefile.pre.in
 ===================================================================
---- Python-3.5.0.orig/Makefile.pre.in
-+++ Python-3.5.0/Makefile.pre.in
-@@ -215,6 +215,7 @@ LIBOBJS=   @LIBOBJS@
+--- Python-3.5.1.orig/Makefile.pre.in
++++ Python-3.5.1/Makefile.pre.in
+@@ -220,6 +220,7 @@ LIBOBJS=   @LIBOBJS@
  
  PYTHON=               python$(EXE)
  BUILDPYTHON=  python$(BUILDEXE)
@@ -21,7 +21,7 @@ Index: Python-3.5.0/Makefile.pre.in
  
  PYTHON_FOR_BUILD=@PYTHON_FOR_BUILD@
  _PYTHON_HOST_PLATFORM=@_PYTHON_HOST_PLATFORM@
-@@ -272,6 +273,7 @@ LIBFFI_INCLUDEDIR= @LIBFFI_INCLUDEDIR@
+@@ -276,6 +277,7 @@ LIBFFI_INCLUDEDIR= @LIBFFI_INCLUDEDIR@
  ##########################################################################
  # Parser
  PGEN=         Parser/pgen$(EXE)
@@ -29,16 +29,16 @@ Index: Python-3.5.0/Makefile.pre.in
  
  PSRCS=                \
                Parser/acceler.c \
-@@ -494,7 +496,7 @@ build_all_generate_profile:
+@@ -506,7 +508,7 @@ build_all_generate_profile:
  
  run_profile_task:
        : # FIXME: can't run for a cross build
--      $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK)
-+      $(RUNSHARED) $(HOSTPYTHON) $(PROFILE_TASK)
+-      $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
++      $(LLVM_PROF_FILE) $(RUNSHARED) $(HOSTPYTHON) $(PROFILE_TASK) || true
  
- build_all_use_profile:
-       $(MAKE) all CFLAGS_NODIST="$(CFLAGS) -fprofile-use -fprofile-correction"
-@@ -764,7 +766,7 @@ $(IO_OBJS): $(IO_H)
+ build_all_merge_profile:
+       $(LLVM_PROF_MERGER)
+@@ -779,7 +781,7 @@ $(IO_OBJS): $(IO_H)
  
  $(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
                @$(MKDIR_P) Include
@@ -47,7 +47,7 @@ Index: Python-3.5.0/Makefile.pre.in
  $(GRAMMAR_C): $(GRAMMAR_H)
                touch $(GRAMMAR_C)
  
-@@ -953,7 +955,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Programs/pyth
+@@ -968,7 +970,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Programs/pyth
  ######################################################################
  
  TESTOPTS=     $(EXTRATESTOPTS)
@@ -56,7 +56,7 @@ Index: Python-3.5.0/Makefile.pre.in
  TESTRUNNER=   $(TESTPYTHON) $(srcdir)/Tools/scripts/run_tests.py
  TESTTIMEOUT=  3600
  
-@@ -1440,7 +1442,7 @@ frameworkinstallstructure:       $(LDLIBRARY)
+@@ -1455,7 +1457,7 @@ frameworkinstallstructure:       $(LDLIBRARY)
                fi; \
        done
        $(LN) -fsn include/python$(LDVERSION) $(DESTDIR)$(prefix)/Headers
@@ -65,7 +65,7 @@ Index: Python-3.5.0/Makefile.pre.in
        $(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
        $(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
        $(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
-@@ -1506,7 +1508,7 @@ config.status:   $(srcdir)/configure
+@@ -1521,7 +1523,7 @@ config.status:   $(srcdir)/configure
  
  # Run reindent on the library
  reindent:
@@ -74,7 +74,7 @@ Index: Python-3.5.0/Makefile.pre.in
  
  # Rerun configure with the same options as it was run last time,
  # provided the config.status script exists
-@@ -1639,7 +1641,7 @@ funny:
+@@ -1656,7 +1658,7 @@ funny:
  
  # Perform some verification checks on any modified files.
  patchcheck: all
similarity index 98%
rename from meta/recipes-devtools/python/python3_3.5.0.bb
rename to meta/recipes-devtools/python/python3_3.5.1.bb
index 6184c79fb1e46e90df5d73829a715a4e48340652..0d9a4cc9357c2e28623fbfe9e0a282a7e83c996b 100644 (file)
@@ -39,8 +39,8 @@ SRC_URI += "\
             file://use_packed_importlib.patch \
             file://configure.ac-fix-LIBPL.patch \
            "
-SRC_URI[md5sum] = "d149d2812f10cbe04c042232e7964171"
-SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2e2be91"
+SRC_URI[md5sum] = "e9ea6f2623fffcdd871b7b19113fde80"
+SRC_URI[sha256sum] = "c6d57c0c366d9060ab6c0cdf889ebf3d92711d466cc0119c441dbf2746f725c9"
 
 # exclude pre-releases for both python 2.x and 3.x
 UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"