]> code.ossystems Code Review - openembedded-core.git/commitdiff
powertop: upgrade from 1.11 to the latest version 1.13
authorDexuan Cui <dexuan.cui@intel.com>
Fri, 27 Aug 2010 09:11:02 +0000 (17:11 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 08:50:48 +0000 (09:50 +0100)
update HOMEPAGE;
add RRECOMMENDS_${PN} = "pciutils" as powertop 1.13 needs lspci;
add EXTRA_OEMAKE = "VERSION=\"${PV}\" to make the build succeed;
fix coding style: 4 SPACEs --> 1 TAB.

fix RRECOMMENDS to RDEPENDS

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/recipes-kernel/powertop/powertop_1.13.bb [moved from meta/recipes-kernel/powertop/powertop_1.11.bb with 61% similarity]

similarity index 61%
rename from meta/recipes-kernel/powertop/powertop_1.11.bb
rename to meta/recipes-kernel/powertop/powertop_1.13.bb
index 371fc62e352dcf5d3a007e7fc726d5c94b76bb61..c52f2830b845cfec14e98ed7b67adb9854541b8c 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
-HOMEPAGE = "http://www.linuxpowertop.org/"
+HOMEPAGE = "http://www.lesswatts.org/"
 BUGTRACKER = "http://bugzilla.lesswatts.org/"
 
 LICENSE = "GPLv2"
@@ -7,17 +7,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 DEPENDS = "virtual/libintl ncurses"
 
+# powertop 1.13 needs lspci
+REPENDS_${PN} = "pciutils"
+
 PR = "r0"
 
 SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
 
 CFLAGS += "${LDFLAGS}"
+EXTRA_OEMAKE = "VERSION=\"${PV}\""
 
 do_configure() {
-    # We do not build ncurses with wide char support
-    sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+       # We do not build ncurses with wide char support
+       sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
 }
 
 do_install() {
-    oe_runmake install DESTDIR=${D}
+       oe_runmake install DESTDIR=${D}
 }
+