]> code.ossystems Code Review - openembedded-core.git/commitdiff
autoconf: Remove code checking for hardcoded /usr/local
authorKhem Raj <raj.khem@gmail.com>
Wed, 3 Aug 2011 21:12:29 +0000 (14:12 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Aug 2011 16:12:59 +0000 (17:12 +0100)
This code is only relevant for AIX and causes
problems with OE QA sniffer which detects -L/usr/local/lib
on linker commandline during cross compile and rightly barfs

This only happens when getloadavg() is not found in libc
so we do not reach that code with eglibc but only with uclibc

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/autoconf/autoconf/remove-usr-local-lib-from-m4.patch [new file with mode: 0644]
meta/recipes-devtools/autoconf/autoconf_2.68.bb

diff --git a/meta/recipes-devtools/autoconf/autoconf/remove-usr-local-lib-from-m4.patch b/meta/recipes-devtools/autoconf/autoconf/remove-usr-local-lib-from-m4.patch
new file mode 100644 (file)
index 0000000..55d2e2f
--- /dev/null
@@ -0,0 +1,29 @@
+We have problem using hardcoded directories like /usr/local here
+which will be checked for cross builds. This is a special case which
+is valid for AIX only. We do not have AIX as one of our supported
+build host or target. Therefore we get rid of the hardcoded paths
+and make life easier for cross compilation process.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [Upstream does care for AIX while we may not]
+Index: autoconf-2.68/lib/autoconf/functions.m4
+===================================================================
+--- autoconf-2.68.orig/lib/autoconf/functions.m4       2010-09-22 14:52:19.000000000 -0700
++++ autoconf-2.68/lib/autoconf/functions.m4    2011-08-03 11:57:05.822199513 -0700
+@@ -749,15 +749,6 @@ if test $ac_have_func = no; then
+     [LIBS="-lutil $LIBS" ac_have_func=yes ac_cv_func_getloadavg_setgid=yes])
+ fi
+-if test $ac_have_func = no; then
+-  # There is a commonly available library for RS/6000 AIX.
+-  # Since it is not a standard part of AIX, it might be installed locally.
+-  ac_getloadavg_LIBS=$LIBS
+-  LIBS="-L/usr/local/lib $LIBS"
+-  AC_CHECK_LIB(getloadavg, getloadavg,
+-             [LIBS="-lgetloadavg $LIBS"], [LIBS=$ac_getloadavg_LIBS])
+-fi
+-
+ # Make sure it is really in the library, if we think we found it,
+ # otherwise set up the replacement function.
+ AC_CHECK_FUNCS(getloadavg, [],
index 3b196a641867b020728c5dcf2480ce7431aa0043..c6209a37eb10d389f6aad95ef84a9d378f66ec14 100644 (file)
@@ -1,6 +1,6 @@
 require autoconf.inc
 
-PR = "r1"
+PR = "r2"
 
 PARALLEL_MAKE = ""
 
@@ -16,6 +16,7 @@ SRC_URI += "file://autoreconf-include.patch \
            file://autoheader-nonfatal-warnings.patch \
            ${@['file://path_prog_fixes.patch', ''][bb.data.inherits_class('native', d)]} \
             file://config_site.patch \
+            file://remove-usr-local-lib-from-m4.patch \
            "
 
 SRC_URI[md5sum] = "864d785215aa60d627c91fcb21b05b07"