]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: Skip assembler optimized code for powerpc64 with musl
authorSerhey Popovych <serhe.popovych@gmail.com>
Fri, 14 Dec 2018 17:54:37 +0000 (19:54 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 25 Feb 2019 22:25:05 +0000 (22:25 +0000)
This code is written for elfv1 ABI in mind and linked as such: disable
all optimizations at the moment when building for powerpc64 with musl.

(From OE-Core rev: bee9e807430178426b2a5635b573ae285e889c39)

Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb
meta/recipes-connectivity/openssl/openssl_1.1.1a.bb

index 42f9bcfdcc3e748af2987a0eb303873292201834..0925af3456d881c9ae9699addf3c6bad37ea3524 100644 (file)
@@ -82,6 +82,7 @@ CCACHE = ""
 
 TERMIO ?= "-DTERMIO"
 TERMIO_libc-musl = "-DTERMIOS"
+EXTRA_OECONF_append_libc-musl_powerpc64 = " no-asm"
 
 CFLAG = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
          ${TERMIO} ${CFLAGS} -Wall"
index 8bc4a1e8ec6a3dfe0aa2d98563e6d1bdb2278151..0fc385fc1482c0a7e4737fd34ecac67f9acff189 100644 (file)
@@ -34,6 +34,7 @@ do_configure[cleandirs] = "${B}"
 #| ./libcrypto.so: undefined reference to `setcontext'
 #| ./libcrypto.so: undefined reference to `makecontext'
 EXTRA_OECONF_append_libc-musl = " no-async"
+EXTRA_OECONF_append_libc-musl_powerpc64 = " no-asm"
 
 # This prevents openssl from using getrandom() which is not available on older glibc versions
 # (native versions can be built with newer glibc, but then relocated onto a system with older glibc)