]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: fix ldd RTLDLIST
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 28 Feb 2013 11:56:26 +0000 (13:56 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 2 Mar 2013 12:53:38 +0000 (12:53 +0000)
The sed expression for retrieving the previous RTLDLIST from ldd script
was also retrieving the double-quotes. Hence, we ended up with a
RTLDLIST like below and ldd would fail:

RTLDLIST=""/lib/ld-linux.so.2 /lib64/ld-linux-x86-64.so.2
/libx32/ld-linux-x32.so.2" /lib/ld-linux-x86-64.so.2"

[YOCTO #3903]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/eglibc/eglibc_2.17.bb

index fb49ac4535e954f40e8846378c48cc2d9a885d2a..65269784693eb40b8d36c6f8af804c92cf21c301 100644 (file)
@@ -144,7 +144,7 @@ do_compile () {
        echo "Adjust ldd script"
        if [ -n "${RTLDLIST}" ]
        then
-               prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST=\(.*\)$#\1#'`
+               prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
                if [ "${prevrtld}" != "${RTLDLIST}" ]
                then
                        sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"