]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk-update-icon-cache-native: create wrapper script
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Mon, 8 Apr 2013 15:06:41 +0000 (18:06 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 8 Apr 2013 15:56:01 +0000 (16:56 +0100)
When using the sstate from another build machine, the path to the pixbuf
loader's cache points to a path on the remote machine. Hence, the update
of the icon cache fails on host.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb

index 93c30a75b1f8c58b87a53c0394d87efdc8f03e4a..73b7644845e26da29862cf65ff60e5c494c811b9 100644 (file)
@@ -40,4 +40,8 @@ do_compile() {
 do_install() {
        install -d ${D}${bindir}
         install -m 0755 ${B}/gtk-update-icon-cache ${D}${bindir}
+
+       create_wrapper ${D}/${bindir}/gtk-update-icon-cache \
+               GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders.cache
+
 }