]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: Change link of ${baselib} to lib64 for 64bits system
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Mon, 17 Oct 2011 09:24:34 +0000 (17:24 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Oct 2011 12:42:03 +0000 (13:42 +0100)
Correct two faults:

1 Binaries of lsb test suite need ld-linux.so* in /lib64.
for example:
Target$ ./lsbcmdchk
-sh: ./lsbcmdchk: No such file or directory
Target$ strings lsbcmdchk | grep "ld-"
/lib64/ld-lsb-x86-64.so.3

"lsbcmdchk" from lsb test suite is a binary program.
A new modification to lsb_1.4.bb caused that binaries from lsb test suite can't run
because binaries of lsb test suite need ld-linux.so* in /lib64.
But the link is changed due to adding multilib. I changed this link again.

2 correct mandir
Waring will appear when running task task do_populate_sysroot

NOTE: package lsb-1.4-r2: task do_populate_sysroot: Succeeded
WARNING: For recipe lsb, the following files were installed but not shipped in any package:
WARNING:   /{datadir}/man/man1/lsb_release.1.gz

I changed mandir=${D}/man to mandir=${D}/${datadir}/man

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsb_1.4.bb

index d47201265ef8ac4729d904b5c3ce0fc8e63c9fee..7cecdf21bd0c48a76f263c8d833bc313e8dc74c8 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "LSB support for Poky Linux"
 SECTION = "console/utils"
 HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
 LICENSE = "GPLv2+"
-PR = "r1"
+PR = "r2"
 
 LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
 
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "99321288f8d62e7a1d485b7c6bdccf06766fb8ca603c6195806e4457fd
 S = ${WORKDIR}/lsb-release-${PV}
 
 do_install(){
-       oe_runmake install prefix=${D}  mandir=${D}/man/ DESTDIR=${D} 
+       oe_runmake install prefix=${D}  mandir=${D}/${datadir}/man/ DESTDIR=${D} 
        mkdir -p ${D}/bin
        mkdir -p ${D}/${baselib}
        mkdir -p ${D}/etc/lsb-release.d
@@ -69,7 +69,9 @@ do_install_append(){
        install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
        if [ "${TARGET_ARCH}" == "x86_64" ];then
               cd ${D}
-              ln -sf ${baselib} lib
+               if [ "${baselib}" != "lib64" ]; then
+                   ln -sf ${baselib} lib64
+               fi
               cd ${D}/${baselib}
                ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
                ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
@@ -82,7 +84,9 @@ do_install_append(){
  
        if [ "${TARGET_ARCH}" == "powerpc64" ];then
               cd ${D}
-              ln -sf ${baselib} lib
+               if [ "${baselib}" != "lib64" ]; then
+                   ln -sf ${baselib} lib64
+               fi
                cd ${D}/${baselib}
                ln -sf ld64.so.1 ld-lsb-ppc64.so.2
                ln -sf ld64.so.1 ld-lsb-ppc64.so.3