]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: Add a new upstream u-boot recipe
authorDarren Hart <dvhart@linux.intel.com>
Wed, 19 Jan 2011 18:07:25 +0000 (10:07 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Jan 2011 11:18:36 +0000 (11:18 +0000)
uboot-omap3 appears to be fairly stale (last commit in April 2010) while
the upstream u-boot is making regular tagged releases. Add a new recipe
using the upstream u-boot repository.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Tom Zanussi <tom.zanussi@intel.com>
CC: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-bsp/uboot/u-boot.inc
meta/recipes-bsp/uboot/u-boot_git.bb [new file with mode: 0644]

index b5082788000c2e041d89fb6f872c0ff11eee2c39..c40d8607edb9790f0540ee9d71728feab679871e 100644 (file)
@@ -173,6 +173,7 @@ SRCREV_pn-trace-cmd ??= ${TRACECMDREV}
 SRCREV_pn-kernelshark ??= ${TRACECMDREV}
 SRCREV_pn-tidy ??= "e25416e1293e1074bfa6727c80527dcff5b1f3cb"
 SRCREV_pn-u-boot-omap3 ??= "f40f6db278f602b55820693634a7256b0b4e4b80"
+SRCREV_pn-u-boot ??= "v2010.12"
 SRCREV_pn-ubootchart ??= "10"
 SRCREV_pn-webkit-gtk ??= "62027"
 SRCREV_pn-web-webkit ??= "130"
index 889f6215ed30d1f0c563d16bd2ee7ffae0ae777e..6363474e532a73a6e3b68e3be2bf30a35b21f620 100644 (file)
@@ -9,7 +9,8 @@ inherit deploy
 
 PARALLEL_MAKE=""
 
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+# GCC 4.5.1 builds unusable binaries using -Os, remove it from OPTFLAGS
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} OPTFLAGS=''"
 
 UBOOT_MACHINE ?= "${MACHINE}_config"
 UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
diff --git a/meta/recipes-bsp/uboot/u-boot_git.bb b/meta/recipes-bsp/uboot/u-boot_git.bb
new file mode 100644 (file)
index 0000000..16a1dbe
--- /dev/null
@@ -0,0 +1,21 @@
+require u-boot.inc
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b \
+                    file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE}"
+
+PV = "v2010.12+${PR}+git${SRCPV}"
+PR="r0"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+UBOOT_MACHINE_beagleboard = "omap3_beagle_config"
+UBOOT_MACHINE_overo = "omap3_overo_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(beagleboard|overo)"