]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: Fix for automake update
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Jan 2012 16:01:56 +0000 (16:01 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Jan 2012 16:03:59 +0000 (16:03 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch [new file with mode: 0644]
meta/recipes-devtools/valgrind/valgrind_3.7.0.bb

diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch
new file mode 100644 (file)
index 0000000..866facf
--- /dev/null
@@ -0,0 +1,45 @@
+Upstream-Status: Pending
+
+automake version 1.11.2 has made use of dir variables more strict.
+the use of pkglibdir with DATA var results in automake errors.
+
+This commits uses pkgdatadir var instead of pkglibdir to avoid 
+the strict check errors.
+
+RP 2012/1/4
+
+Index: valgrind-3.7.0/Makefile.am
+===================================================================
+--- valgrind-3.7.0.orig/Makefile.am    2012-01-04 15:55:07.034044860 +0000
++++ valgrind-3.7.0/Makefile.am 2012-01-04 15:55:55.034035120 +0000
+@@ -61,7 +61,7 @@
+ # default.supp, as it is built from the base .supp files at compile-time.
+ dist_noinst_DATA = $(SUPP_FILES)
+-pkglib_DATA = default.supp
++pkgdata_DATA = default.supp
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = valgrind.pc
+Index: valgrind-3.7.0/coregrind/Makefile.am
+===================================================================
+--- valgrind-3.7.0.orig/coregrind/Makefile.am  2012-01-04 15:55:02.090043851 +0000
++++ valgrind-3.7.0/coregrind/Makefile.am       2012-01-04 15:55:30.270044097 +0000
+@@ -495,7 +495,7 @@
+       m_gdbserver/powerpc-altivec64l.xml
+ # so as to make sure these get copied into the install tree
+-pkglib_DATA  = $(GDBSERVER_XML_FILES)
++pkgdata_DATA  = $(GDBSERVER_XML_FILES)
+ # so as to make sure these get copied into the tarball
+ EXTRA_DIST  += $(GDBSERVER_XML_FILES)
+@@ -506,7 +506,7 @@
+ all-local: inplace-noinst_PROGRAMS inplace-noinst_DSYMS
+       mkdir -p $(inplacedir); \
+-      for f in $(pkglib_DATA); do \
++      for f in $(pkgdata_DATA); do \
+         rm -f $(inplacedir)/$$f; \
+         ln -f -s ../$(subdir)/$$f $(inplacedir); \
+       done
index 03cdd28aff45563ae118a13453ad526f11c138c7..f4f3131c5800ef1bf0cfa7927788cbac0d825a7a 100644 (file)
@@ -7,12 +7,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
                     file://include/valgrind.h;beginline=1;endline=56;md5=aee56014c1dd64260a59fd4df38752f6 \
                     file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
 DEPENDS = "virtual/libx11"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
           file://fix_issue_caused_by_ccache.patch \
            file://fix_unsupporting_kernel_3.patch \
            file://fixed-perl-path.patch \
+           file://fix_for_automake_1.11.2.patch \
            file://configure-fix.patch"
 
 SRC_URI[md5sum] = "a855fda56edf05614f099dca316d1775"