]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr: remove the use of ${SHELL} to avoid bash/dash confliction
authorHongxu Jia <hongxu.jia@windriver.com>
Fri, 11 Apr 2014 10:31:38 +0000 (18:31 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 23 May 2014 16:09:38 +0000 (09:09 -0700)
While multible hosts sharing a common sstate cache, the fist host using
bash as default shell and build apr, the second host using dash as
default shell and build apr-util, there was a failure in apr-util:
...
| /bin/sh: 0: Can't open i586-poky-linux-libtool
| make[1]: *** [dbm/apr_dbm_gdbm.lo] Error 127
| make[1]: *** Waiting for unfinished jobs....
| make[1]: Leaving directory
`tmp/work/i586-poky-linux/apr-util/1.5.2-r0/apr-util-1.5.2'
...

The quick way to reproduce the defect in Ubuntu 1204:
1. Create a new build
2. sudo dpkg-reconfigure dash <set bash as /bin/sh>
3. bitbake apr
4. sudo dpkg-reconfigure dash <set dash as /bin/sh>
5. bitbake apr-util

Remove the use of $(SHELL) in the apr could avoid this issue.

(From OE-Core rev: 53af71200b6f6d117e1e7dc2e7a7d21c6faab8f9)

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/apr/apr_1.4.8.bb

index 4d36585a3e3ef7ac04ab02254b8773a35d1bcb29..7a130d1bdc3ce20a4e4c56519d9cdfc4b285cd2c 100644 (file)
@@ -56,7 +56,7 @@ apr_sysroot_preprocess () {
        cp ${S}/build/apr_rules.mk $d/
        sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
        sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
-       sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g $d/apr_rules.mk
+       sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
        sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
        cp ${S}/build/mkdir.sh $d/
        cp ${S}/build/make_exports.awk $d/