]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: use pidof command in killproc() function
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:21:01 +0000 (14:21 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 13 Jun 2008 14:21:01 +0000 (14:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4643 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/initscripts/initscripts-1.0/functions
meta/packages/initscripts/initscripts_1.0.bb

index 358fc6edb3f4f4f8391e8d245590020046a1e967..514618770a7895f7d4e6213eca440b160d561612 100644 (file)
@@ -9,9 +9,6 @@ cpuinfo_id() {          # return the Hardware module ID
 }
 
 killproc() {           # kill the named process(es)
-    pid=`/bin/ps -e x |
-         /bin/grep $1 |
-         /bin/grep -v grep |
-         /bin/sed -e 's/^  *//' -e 's/ .*//'`
+    pid=`/bin/pidof $1`
     [ "$pid" != "" ] && kill $pid
 }
index 6f65e12bb4a6d26d21537c78c90e0e9e51458077..16f987e49ec475b178e122dcf99a330aeb2ed2a0 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r109"
+PR = "r110"
 
 SRC_URI = "file://functions \
            file://halt \