]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta/conf/local.conf.sample: improve comments/layout
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 26 Jul 2011 09:59:56 +0000 (10:59 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 10:54:48 +0000 (11:54 +0100)
Some additions and grammar fixes to the comments, as well as moving
the locale options to the same place.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/conf/local.conf.sample

index 7a5e5339eaf8845a625d26797c21e27976121047..f75d248143ce8598d01af943086533c0b9060995 100644 (file)
@@ -2,10 +2,10 @@
 CONF_VERSION = "1"
 
 # Uncomment and change to cache the files Poky downloads in an alternative
-# location, default it ${TOPDIR}/downloads
+# location, default is ${TOPDIR}/downloads
 #DL_DIR ?= "${TOPDIR}/downloads"
 # Uncomment and change to cache Poky's built staging output in an alternative
-# location, default ${TOPDIR}/sstate-cache
+# location, default is ${TOPDIR}/sstate-cache
 #SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
 
 # Uncomment and set to allow bitbake to execute multiple tasks at once.
@@ -26,6 +26,8 @@ MACHINE ??= "qemux86"
 #MACHINE ?= "qemux86"
 #MACHINE ?= "qemux86-64"
 
+# BBMASK is a regular expression that can be used to tell BitBake to ignore
+# certain recipes.
 BBMASK = ""
 
 # EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images 
@@ -41,9 +43,9 @@ BBMASK = ""
 # "debug-tweaks"   - make an image for suitable of development
 #                    e.g. ssh root access has a blank password
 # There are other application targets too, see meta/classes/core-image.bbclass 
-# and meta/packages/tasks/task-core.bb for more details.
-
-EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+# and meta/recipes-core/tasks/task-core.bb for more details.
+# The -sdk image includes these features by default now.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
 
 # A list of packaging systems used in generated images
 # The first package type listed will be used for rootfs generation
@@ -119,8 +121,6 @@ PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
 # Uncomment this if you want BitBake to emit the log if a build fails.
 BBINCLUDELOGS = "yes"
 
-ENABLE_BINARY_LOCALE_GENERATION = "1"
-
 # The architecture to build SDK items for, by setting this you can build SDK
 # packages for architectures other than the host i.e. building i686 packages
 # on an x86_64 host.
@@ -150,6 +150,12 @@ ENABLE_BINARY_LOCALE_GENERATION = "1"
 #case, which will take much time.
 #TEST_SERIALIZE = "1"
 
+# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
+# packages at build time using qemu-native. Disabling it (by setting it to 0)
+# will save some build time at the expense of breaking i18n on devices with
+# less than 128MB RAM.
+ENABLE_BINARY_LOCALE_GENERATION = "1"
+
 # Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
 # wish to perform the time-consuming step of generating all LIBC locales.
 # NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
@@ -160,10 +166,10 @@ ENABLE_BINARY_LOCALE_GENERATION = "1"
 #IMAGE_LINGUAS ?= "en-gb"
 #LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
 
-# This value is currently used by PSEUDO to determine if the recipe should
+# This value is currently used by pseudo to determine if the recipe should
 # build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
 #
-# PSEUDO will attempt to determine if a 32-bit wrapper is necessary, but 
+# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
 # it doesn't always guess properly.  If you have 32-bit executables on 
 # your 64-bit build system, you likely want to set this to "0", 
 # otherwise you could end up with incorrect file attributes on the