]> code.ossystems Code Review - openembedded-core.git/commitdiff
task-core-boot.bb: Add PACKAGE definition to facilitate multilib
authorDongxiao Xu <dongxiao.xu@intel.com>
Fri, 5 Aug 2011 05:48:25 +0000 (13:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Aug 2011 16:30:13 +0000 (17:30 +0100)
If there is no PACKAGES defined in bb file, its default definition would
be "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev ${PN}-staticdev ${PN}-locale".
In multilib case, ${PN} is extended with ${MLPREFIX}, so there is no
rename occurred for the PACKAGES. Therefore for task-core-boot,
RDEPENDS_lib32-task-core-boot will be empty, resulting busybox,
tinylogin, etc. are not bulit out.

This fixed the issue that /bin/sh is not provided while do_rootfs.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/tasks/task-core-boot.bb

index 5aea77169ff36f665e00c5fcbfeb2c052d93f9a1..eb2b5484a2ab70c7b88ef1383840625314676062 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 DEPENDS = "virtual/kernel"
 ALLOW_EMPTY = "1"
-PR = "r7"
+PR = "r8"
 
 #
 # Set by the machine configuration with packages essential for device bootup
@@ -17,6 +17,12 @@ PR = "r7"
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
 
+PACKAGES = "\
+    task-core-boot \
+    task-core-boot-dbg \
+    task-core-boot-dev \
+"
+
 RDEPENDS_task-core-boot = "\
     base-files \
     base-passwd \