]> code.ossystems Code Review - openembedded-core.git/commitdiff
rxvt-unicode: Check existence of acinclude.m4
authorRadu Moisan <radu.moisan@intel.com>
Thu, 11 Jul 2013 12:47:45 +0000 (12:47 +0000)
committerSaul Wold <sgw@linux.intel.com>
Fri, 12 Jul 2013 17:12:11 +0000 (10:12 -0700)
copy should only happen if acinclude.m4 doesn't exist

Signed-off-by: Radu Moisan <radu.moisan@intel.com>
meta/recipes-sato/rxvt-unicode/rxvt-unicode_9.18.bb

index 9a4761757a4f266e9ccc35d9c82cccda1f8b5d0d..e417957f615673f6a6b5a09bf133876030eb78b9 100644 (file)
@@ -42,7 +42,9 @@ EXTRA_OECONF = "--enable-menubar --enable-xim \
                --with-x=${STAGING_DIR_HOST}${prefix}"
 
 do_configure_prepend () {
-       cp ${S}/aclocal.m4 ${S}/acinclude.m4
+       if [ ! -e ${S}/acinclude.m4 ]; then
+               cp ${S}/aclocal.m4 ${S}/acinclude.m4
+       fi
 }
 
 do_compile_prepend () {