]> code.ossystems Code Review - openembedded-core.git/commitdiff
gst-openmax: fix build with GLib 2.40 onwards
authorRoss Burton <ross.burton@intel.com>
Mon, 12 May 2014 12:14:47 +0000 (13:14 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 May 2014 18:24:00 +0000 (19:24 +0100)
GLib 2.40 adds g_ptr_array_insert, but gst-openmax is definining that as a
static helper function.  Rename the static function so it doesn't conflict with
GLib's namespace.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch [new file with mode: 0644]
meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb

diff --git a/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch b/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch
new file mode 100644 (file)
index 0000000..5965bba
--- /dev/null
@@ -0,0 +1,46 @@
+Rename static functions that use GLib naming conventions as one of them
+(g_ptr_array_insert) has now been added to GLib.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/omx/gstomx_util.c b/omx/gstomx_util.c
+index 423e441..579dbf5 100644
+--- a/omx/gstomx_util.c
++++ b/omx/gstomx_util.c
+@@ -85,7 +85,7 @@ static gboolean initialized;
+  */
+ static void
+-g_ptr_array_clear (GPtrArray * array)
++omx_g_ptr_array_clear (GPtrArray * array)
+ {
+   guint index;
+   for (index = 0; index < array->len; index++)
+@@ -93,7 +93,7 @@ g_ptr_array_clear (GPtrArray * array)
+ }
+ static void
+-g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
++omx_g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
+ {
+   if (index + 1 > array->len) {
+     g_ptr_array_set_size (array, index + 1);
+@@ -394,7 +394,7 @@ g_omx_core_unload (GOmxCore * core)
+   }
+   core_for_each_port (core, g_omx_port_free);
+-  g_ptr_array_clear (core->ports);
++  omx_g_ptr_array_clear (core->ports);
+ }
+ static inline GOmxPort *
+@@ -418,7 +418,7 @@ g_omx_core_new_port (GOmxCore * core, guint index)
+   }
+   port = g_omx_port_new (core, index);
+-  g_ptr_array_insert (core->ports, index, port);
++  omx_g_ptr_array_insert (core->ports, index, port);
+   return port;
+ }
index ea3b66ba8c1dea2dc5c41c3a07214a8604f59a75..4e22f46532d3e7731c5c0590bf3a66ce90c87ddf 100644 (file)
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24 \
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-openmax/gst-openmax-${PV}.tar.bz2 \
            file://gcc_4.6.patch \
+           file://ptr-array.patch \
            "
 
 inherit autotools